Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed gnome-sushi and try to test it, but it doesn't work. I tested it by typing "sushi" into Terminal it doesn't work. I get an error message.

(sushi-start:20986): Gdk-WARNING **: The program 'sushi-start' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadLength (poly request too large or internal Xlib length erro'.
  (Details: serial 221 error_code 16 request_code 155 minor_code 30)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

I tried it by logout and login but it doesn't work. I know that it should work with both unity and gnome-shell. I tested it from Terminal with sudo sushi and tried to preview a file in nautilus and get this error this time:

Could not load classifier cascade /usr/share/opencv/haarcascades/haarcascade_frontalface_alt2.xml

I searched a lot but didn't find a solution for my problem on the net and decided to ask you.

Thanks in advance

share|improve this question

closed as off topic by Jorge Castro, Marco Ceppi Oct 16 '11 at 18:07

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

Welcome to Ask Ubuntu! This question should instead be filed as a bug report, thanks! Instructions here. – Alvin Row Oct 15 '11 at 23:08
To correct the error consider uninstalling frei0r-plugins as per – gliptak Apr 22 '12 at 13:49

I don't think that's how you use it. I've installed gnome-sushi on my 11.10 desktop, and now can use it just by selecting a file or folder in Nautilus and pressing Space to open a preview. AFAIK you shouldn't need to run it from a terminal.

share|improve this answer
I just report it as a bug on launchpad. I tried now by adding gnome-sushi to autostart. After login the processes sushi and sushi-start are running but if I try to preview a file (.jpg) by pressing Space both processes does abort. And if I deselect sushi in autostart it doesn't start by itself after login. – cegerxwin Oct 15 '11 at 23:46

Not the answer you're looking for? Browse other questions tagged or ask your own question.