Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I upgraded from Ubuntu 11.04 (using fglrx driver from AMD site) to 11.10. After upgrade 3D acceleration is not working with my Radeon HD 5570 fails to run any program with 3D acceleration. I tried to remove ATI driver and reinstall it but to no avail. I also tried Live CD and there open source driver works great, but I don't know how to enable it on my computer.

Uninstalling fglrx didn't work. Any ideas?

share|improve this question
    
try this. wiki.cchtml.com/index.php/… –  duffydack Oct 15 '11 at 21:19
    
Just tried it, didn't help. I am starting to believe reinstalling of OS is the option. –  Rūdolfs Oct 15 '11 at 21:40
    
just looked at dmesg; it seems there are parts of fglrx remaining. I'll see what I can do –  Rūdolfs Oct 15 '11 at 21:58
    
possible duplicate of Is my ATI graphics card supported in Ubuntu? –  Bruno Pereira Feb 13 '12 at 23:26
add comment

2 Answers

Do this to remove all the fglrx traces from your system:

sudo apt-get purge fglrx*

Remove your xorg.conf

sudo rm /etc/X11/xorg.conf

Reinstall xorg

sudo apt-get install --reinstall xserver-xorg-core libgl1-mesa-glx:i386 libgl1-mesa-dri:i386 libgl1-mesa-glx:amd64 libgl1-mesa-dri:amd64

Configure Xorg

sudo dpkg-reconfigure xserver-xorg

Reboot:

sudo reboot

After the reboot all the fglrx drivers will be gone, you will be using default ones.

share|improve this answer
    
This worked perfectly for me. Thanks. It's one of those things you can usually work your way out of when there's a problem, but your instructions worked first shot. My only difference was I didn't have the i386 packages installed in the first place so I omitted them. Thanks again. –  Mark Russell Nov 7 '11 at 16:32
add comment

The problem indeed was previous ATI driver. It was removed, using command:

sudo ./ati-driver-installer-11-9-x86.x86_64.run --uninstall=force

the executable was downloaded from AMD ATI homepage.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.