Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My PC has a build-in VT1828S chip. The connection between PC and monitor (which has built-in speakers) is through an HDMI cable.

Audio preferences shows 2 devices for audio output: analog stereo and RS880 Audio Device [Radeon HD 4200] digital stereo (HDMI).

When I plug a headphone in the rear jack and I choose the former device, everything works. When I choose the latter device, instead, no sound is heard, and video playback is too fast. It is as if video frames want to synchronise with the audio timing, but the audio timing information is wrong.

HDMI audio worked perfectly with Ubuntu 11.04, but stopped after 11.10 upgrade.

share|improve this question
    
i had the same problem and i did exactly as described here. The HDMI sound is now working after boot up. but after a while the sound is gone and the HDMI option vanish from the auto setup. After log off and on, the sound is back. That's quite annoying. No solution so far... –  user75583 Jul 7 '12 at 10:20
add comment

1 Answer

HDMI Audio is disabled by default on kernel 3.0+ due to a black screen on some monitors to get audio working again:

  1. Go to the terminal and write:

    gksudo gedit /etc/default/grub
    
  2. Then change the line:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    

    to

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.audio=1"
    
  3. Type on the terminal:

    sudo update-grub
    
  4. Reboot and your HDMI sound will work again.

Here's the thread where I found the solution.

share|improve this answer
    
Here is the corresponding bug report: bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/864735 –  Takkat Sep 8 '13 at 7:48
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.