Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Recently I upgraded from 8.04 LTS to 10.04. The previous version had some problems regarding screen settings. X only recognised 1024x768 as resolution of my monitor, mainly because the monitor was not identified correct. With 10.04 the monitor and its resolutions are identified correct and the systems chooses a better resolution. But now the fonts seem blurry. They are hard to read. I tried a larger font size which improves the situation a bit. I also played around with nvidia-settings. If I choose 1024x768 again, the fonts look good. Also some resolutions with specific refresh rates seem better. Another try I made was to change hinting settings. However the best variant was already chosen.

So I run out of ideas for a solution. Do you have any hints? My graphics card is nVidia Corporation C68 [GeForce 7050 PV / nForce 630a] (rev a2).

share|improve this question
    
Post more information about your monitor: is it a CRT or an LCD? –  Broam Aug 2 '10 at 14:58
    
Is it all fonts, or just some? –  mlissner Aug 3 '10 at 20:12
    
It is a CRT monitor. All I can tell is that the manufacturer is Medion, a german based hardware company. I have no manual or something for it. –  qbi Aug 3 '10 at 21:49
add comment

4 Answers 4

You might be using wrong settings for subpixel hinting - it might be turned on when it shouldn't be, depending on your monitor. I've found that 10.04 defaults to having it turned on with LCD panels (haven't tested a CRT in a while.)

Your panel might be also returning the wrong information about the color order.

Check the Appearance settings. nvidia-settings may override the Free Software stack - there's a lot of points where nvidia driver does odd things. Try temporarily removing the nvidia driver to let nouveau drive the hardware and see if the situation improves.

As of note nouveau in Ubuntu 10.04 does not have 3D acceleration, but is quite fine in 2D.

share|improve this answer
    
I tried it, but nouveau sets the screen resolution to 800x600 (or 640x480). ATM I'm trying to find a way to fix this. –  qbi Aug 3 '10 at 21:44
    
Restarting gdm was not enough. When I restarted the whole system the resolution was correct, but the blurry fonts stayed. –  qbi Aug 5 '10 at 13:24
    
Now that you're trying nouveae, see Marcelo's answer. –  Broam Aug 5 '10 at 14:58
add comment

I've read that in 8.04 all vertical lines in fonts are drawn sharply, but in following releases, vertical lines in fonts are blurred a little. It may or may not be the problem you're having, but it's worth looking at. This blog post explains how to revert the setting.

share|improve this answer
    
The original author of the blog article had a LCD monitor. I'm using a CRT. When I tried his suggestion the situation got a bit worse. So I went back to my defaults. –  qbi Aug 5 '10 at 13:25
    
Darn. Well, it was worth a shot. I hope you find the right answer. –  mac9416 Aug 5 '10 at 16:20
add comment

Try changing the font rendering options.

Start with...

System > Preferences > Appearance > Fonts > Details

... and play with the smoothing and hinting options. I know I played a while until I felt the fonts were well rendered.

share|improve this answer
add comment
up vote 1 down vote accepted

I played around with my installation in the last few days. What seemed to help was uninstall all nvidia stuff, remove the old /etc/X11/xorg.conf and reinstall nvidia again. I'll have to go through this old xorg.conf. Maybe there was some strange setting.

I could manage to start the Nouveau driver, but there was no real improvement regarding font settings. The only drawback it had, was the missing 3d acceleration. Thatswhy I went back to nvidia binaries. However in a few weeks I'll try nouveau again. Maybe it has improved in some way.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.