Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I have just bought the above sound card and it is recognised within Ubuntu 11.10 and produces sound using the SPDIF output to my surround reciever.

The problem is that I cannot get it to output anything more than stereo over the SPDIF. In sound settings I cannot set anything other than Digital Stereo (IEC958) Output.

The chipset is cm6206 but is recognised as a "CM106 Like" card.

How do I get 5.1 digital surround sound to work?

Since this is the output for my media centre in the lounge its important that the surround sound works. Any help greatly appreciated.



share|improve this question
Not on the output tab but on the hardware tab, what profile have you there selected? – Bruno Pereira Oct 15 '11 at 20:08

3 Answers 3

Today I was tired of trying to resolve the exact same problem with the same sound card and guess what... I simply installed the paprefs package that adds to your tools pulseaudio preferences; I could then configure my card and voila!!!

share|improve this answer

This chipset is fully supported by Ubuntu so you should be able to use without problems.

Try this:

Click the Speaker top right hand corner, click 'Sound preferences'. Select the 'Hardware' tab. In the drop down menu choose a Profile for your device that meets your speaker layout.

enter image description here

share|improve this answer

you can activate the spdif output in the alsamixer. After that you get stereo sound out of your speakers.

Now you use your Video player (eg. vlc) and configure it to pass trough the sound. With that the reviever gets the digital signal and is able to give you 5.1 sound.

vlc -> extra -> settings -> audio choose Alsa-plugin use spdif if possible and choose your soundcard

worked for me and i hope for you too ;)

have fun Alex

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.