Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Hi As I upgrade my pc to ubuntu 11.10 I can't connect to the wired connection ! It doesn't even find my Device MAC address !!What can I do ?

ifconfig -a

eth0      Link encap:Ethernet  HWaddr ff:ff:ff:ff:ff:ff  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:44 Base address:0x2000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:6647 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6647 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:1333687 (1.3 MB)  TX bytes:1333687 (1.3 MB)

the answer of etc/network/interfaces

auto lo
iface lo inet loopback


sudo lshw -class network

 *-network       
       description: Ethernet interface
       product: RTL8111/8168B PCI Express Gigabit Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:04:00.0
       logical name: eth0
       version: 02
       serial: ff:ff:ff:ff:ff:ff
       size: 1Gbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=N/A latency=0 link=no multicast=yes port=MII speed=1Gbit/s
       resources: irq:44 ioport:c000(size=256) memory:cff20000-cff20fff memory:cff00000-cff0ffff memory:cff10000-cff1ffff


 lspci

00:00.0 Host bridge: Intel Corporation 4 Series Chipset DRAM Controller (rev 03)
00:01.0 PCI bridge: Intel Corporation 4 Series Chipset PCI Express Root Port (rev 03)
00:1a.0 USB Controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #4
00:1a.1 USB Controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #5
00:1a.2 USB Controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #6
00:1a.7 USB Controller: Intel Corporation 82801JI (ICH10 Family) USB2 EHCI Controller #2
00:1b.0 Audio device: Intel Corporation 82801JI (ICH10 Family) HD Audio Controller
00:1c.0 PCI bridge: Intel Corporation 82801JI (ICH10 Family) PCI Express Root Port 1
00:1c.4 PCI bridge: Intel Corporation 82801JI (ICH10 Family) PCI Express Root Port 5
00:1c.5 PCI bridge: Intel Corporation 82801JI (ICH10 Family) PCI Express Root Port 6
00:1d.0 USB Controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #1
00:1d.1 USB Controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #2
00:1d.2 USB Controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #3
00:1d.7 USB Controller: Intel Corporation 82801JI (ICH10 Family) USB2 EHCI Controller #1
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 90)
00:1f.0 ISA bridge: Intel Corporation 82801JIB (ICH10) LPC Interface Controller
00:1f.2 IDE interface: Intel Corporation 82801JI (ICH10 Family) 4 port SATA IDE Controller #1
00:1f.3 SMBus: Intel Corporation 82801JI (ICH10 Family) SMBus Controller
00:1f.5 IDE interface: Intel Corporation 82801JI (ICH10 Family) 2 port SATA IDE Controller #2
01:00.0 VGA compatible controller: nVidia Corporation G92 [GeForce 9600 GSO] (rev a2)
03:00.0 IDE interface: JMicron Technology Corp. JMB368 IDE controller
04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 02)
05:00.0 Memory controller: Conexant Systems, Inc. Device 2d00 (rev 01)


uname -a
Linux mahdiar-EP45-UD3L 3.0.0-15-generic #26-Ubuntu SMP Fri Jan 20 17:23:00 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
share|improve this question
    
Can you give more information about your hardware? –  Bruno Pereira Oct 15 '11 at 20:06
    
Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 02) –  mahdiar Oct 19 '11 at 7:16
    
nobody can help ?? –  mahdiar Oct 22 '11 at 17:45
    
I add it to the main post . –  mahdiar Oct 23 '11 at 18:52
    
I try my notebook and I have the same problem . –  mahdiar Oct 30 '11 at 17:32

2 Answers 2

up vote 6 down vote accepted
+100

The kernel incorrectly matches this NIC with the r8169 kernel module. This is shown by the lshw trace where it shows that the NIC has been disabled.

According to this article, the NIC should be associated with the r8168 kernel module. With the incorrect kernel module you will either get slow speeds or no connection what-so-ever.

According to Launchpad - this is also a recognised bug with Oneiric - however, it looks like it has been resolved for 12.04 since Precise uses a newer kernel (v3.2)


hardware issues

First, let's rule out a NIC hardware failure - NICs can go bad (the firmware/ROM) - an indication of this is the fact that the MAC address is recognised as FF:FF:FF:FF:FF

If you last had a working NIC with Natty (or previous Ubuntu version) - then boot your PC with a LiveUSB/LiveCD.

Test your wired connection - rerun sudo lshw -class network. Look for the MAC address. Also look to see if it still says disabled.

If it still fails to connect via a live usb/cd with the version of ubuntu it last worked with then you have a strong indication of hardware failure.


potential software solutions

Once you have ruled out hardware issues, then lets concentrate on possible software solutions.

For the solutions below you will still need a valid internet connection...

If you have a spare NIC card that is not of this model I would insert this into your PC and connect to the internet via a wired connection. If you can connect via wireless - do so. Otherwise, you may need to move your hard-drive into another computer to do the following and then transfer it back to your original PC.

FIRST - BACKUP YOUR SYSTEM with a good backup tool such as Clonezilla

Suggested Fix 1

According to the launchpad bug report, this is potentially fixed if you enable the proposed repository in software sources and install the package linux-backports-modules-3.0.0

Suggested Fix 2

You may be able to download the Precise kernel (v3.2) and install this.

From the mainline kernel area of launchpad:

Download the amd64 headers.deb, headers_all.deb and the image_amd64.deb files

then install the kernel using the syntax:

sudo dpkg -i [package_name].deb

Suggested Fix 3

This is something you may be able to resolve by downloading the realtek driver and compiling it yourself.

Download the Linux source - at the time of writing this it is v8.028.00

Unpack the tarball :

tar vjxf r8168*.tar.bz2

Change to the directory:

cd r8168-8*

Compile:

sudo ./autorun.sh 

You can check whether the driver is loaded by using following commands.

lsmod | grep r8168
ifconfig -a

If there is a device name, ethX, shown on the monitor, the linux driver is loaded. Then, you can use the following command to activate the ethX.

ifconfig ethX up

Finally, blacklist the r8169 driver add the following to /etc/modprobe.d/blacklist.conf

#blacklist r8169 driver
blacklist r8169

Potential workarounds

A similar bug-report mentioning odd-MAC addresses for the r8169 kernel module on older kernels gave a couple of suggested workarounds.

work around 1

Once booted stop and start the kernel module:

sudo rmmod r8169 && sudo modprobe r8169

work around 2

Boot from your Natty live CD - run ifconfig -a and record the MAC address for eth0.

Boot into oneiric. Examine your udev persistent rules and map the correct MAC address to eth0

sudo cp /etc/udev/rules.d/70-persistent-net.rules /
sudo nano /etc/udev/rules.d/70-persistent-net.rules

change the MAC address. If in doubt - please add to your question the contents of your rules file.

share|improve this answer
    
Thanks . I think The third one is the safest one . I do the same as you describe but it doesn't work . ifconfig -a eth0 Link encap:Ethernet HWaddr ff:ff:ff:ff:ff:ff inet6 addr: fe80::fdff:ffff:feff:ffff/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:0 errors:0 dropped:0 overruns:0 frame:0 TX packets:0 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:0 (0.0 B) TX bytes:0 (0.0 B) Interrupt:44 Base address:0x2000 –  mahdiar Feb 10 '12 at 12:03
    
when did you last have this working? According to this (lists.fedoraproject.org/pipermail/users/2010-December/…) - an ethernet mac address of FF:FF;FF:FF;FF is a sign of hardware failure (the firmware in the NIC has gone bad. –  fossfreedom Feb 10 '12 at 12:24
    
... also (remember to edit your question with all replies) - does the sudo lshw -class network still say "disabled" ? (please update the question with what it says now after doing suggestion3) - if it does then we still have a kernel/hardware issue. Try the backport module and rerun sudo lshw -class network again. Also - we need to confirm or deny the potential hardware issue - boot from a Natty Live CD (or whatever version it last worked) - does the wired connection start to work? If it doesnt I'm afraid the hardware failure is very likely. –  fossfreedom Feb 10 '12 at 12:31
    
no it isn't disabled anymore . I try 11.04 and it works properly . and found device MAC address too. –  mahdiar Feb 11 '12 at 16:09
    
great news - no hardware issue. Dont forget to edit your question with what you have tried. Please try the second suggestion (the new v3.2 kernel) and let us know the results. Thanks. –  fossfreedom Feb 11 '12 at 16:13
HWaddr ff:ff:ff:ff:ff:ff

Really? Is this your real MAC Address or you are spoofing ?? Change your MAC Address from Broadcast address to something else(Spoof another address):

sudo ifconfig eth0 hw ether xx:xx:xx:xx:xx:xx
sudo service networking restart

Place the new MAC Address instead of xx:xx:xx:xx:xx:xx

share|improve this answer
    
It can be a problem with the module as described on another answer here. The user does not refer to any spoofing attempt. –  Bruno Pereira Feb 10 '12 at 11:48
    
Please review your answer, research if needed but be accurate when placing your answer here. The question seems genuine. –  Ringtail Nov 4 '12 at 21:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.