Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've installed Oneiric from scratch (didn't upgrade), and I'm having troubles with desktop effects: Unity is very slow - whenever I click on the workspaces icon, I either get no animation, or the animation just hangs for a second or so before it's completed. Other behaviors feel similarly unresponsive. For example, whenever I try to move a window on the desktop, it will lag behind for a while before it catches up with the mouse pointer. Gnome Shell feels slightly better, but not by much.

The CPU is an AMD Athlon II X2, I have 4 GB RAM, and the video card is is an Nvidia GeForce 6150SE nForce 430.

I've tried playing around with nvidia-settings; I've installed/removed every single Nvidia driver in the repositories (currently using nvidia-173); I've changed the Compiz settings following solutions for similar issues (unchecked "Detect refresh rate", and so on), without any success - in fact, I didn't even manage to make things worse. ;)

glxgears looks great, and it feels like the driver is working really well for everything except desktop effects. Unity 2D is fine, and I'm using it right now.

share|improve this question
    
If it goes very slow that could mean Unity is overheating your graphic card, so I'd suggest you stick with Unity 2D. –  RobinJ Oct 15 '11 at 19:48
    
@WPBloyd Have you also tried out the nouveau driver to see if you get better support there? –  WarriorIng64 Oct 15 '11 at 19:49
    
I did; but all I got using the nouveau driver was a black screen, I had to restore the nvidia driver from the console. I might try it again, though... it certainly won't hurt ;) I'm not sure why only Unity (or Gnome Shell) would be slow... –  WPBloyd Oct 15 '11 at 20:12
    
I'd say that you might be affected by the same bug as I am. Take a look at: 850649 –  user29046 Oct 19 '11 at 18:13
    
Well, in my case gnome-terminal is just as good as it was in 11.04... even using Unity 3D or Gnome Shell –  WPBloyd Oct 20 '11 at 11:03
add comment

2 Answers

I have the same nvidia card (GeForce 6150SE nForce 430) and experienced the exact same problem as WPBloyd (desktop effects were very slow, but it was otherwise fine) using the nvidia driver.

I followed the instructions on this page in order to use the "Nouveau" driver (open-source driver for nvidia cards).

Problem: Need to fully remove -nvidia and installing or reinstall -nouveau from scratch

Here is a recipe which removes all old video drivers, and reinstalls nouveau:

sudo nvidia-settings --uninstall
sudo apt-get remove --purge nvidia*
sudo apt-get remove --purge  xserver-xorg-video-nouveau
sudo apt-get install nvidia-common
sudo apt-get install xserver-xorg-video-nouveau
sudo apt-get install --reinstall  xserver-xorg-core
sudo dpkg-reconfigure xserver-xorg

(I copied what I used; it is the same as on the last link, except that I suppressed server-xorg-video-nv, libgl1-mesa-glx and libgl1-mesa-dri because they did not seem to exist anymore)

It worked for me, I hope this can help somebody else :)

share|improve this answer
    
This worked for me under Precise. Unity is far faster under Nouveau than the proprietary drivers. –  Twirrim Mar 17 '12 at 0:54
    
This made it worse for me. –  Alix Axel Oct 31 '12 at 18:15
    
This is a problem with unity, not the proprietary nvidia drivers. nouveau is vastly inferior to the nvidia drivers; suggesting their replacement just because Canonical fails to provide a window manager capable of working properly under the proprietary drivers (or chooses to do so, just to make a point), is not really an answer to the problem, unless you are willing to consider removing Unity and replacing it with another DE as an equally useful 'solution'. –  cosmix Jan 23 '13 at 10:23
add comment

The only and best recommendation to be done at this moment is to stick with ubuntu-2d. Nvidia and ATI cards and known to slow everything down (tried playing movies yet???) usind the 3d effects. Nothing you can do will solve this 100%, its a driver issue.

share|improve this answer
    
Thank you; I haven't tried playing DVDs yet, but full HD videos (1080p) play flawlessly in full screen. Everything I've tried so far works really great - everything, except desktop effects. –  WPBloyd Oct 15 '11 at 19:58
    
Have huge issues with that, in the end I just stoped using 3d effects. Now I can play games on wine, watch movies, no lag in interface. Did you had to do anything to watch movies or all played well after driver install? The nouveau drivers are known to support the 3d effects better + reduce the lad on the desktop. If you dont use wine or any other programs for 3d you can try them, else just use 2d. –  Bruno Pereira Oct 15 '11 at 20:03
    
I'm afraid I'll have to give up 3D effects as well, but I needed to ask here just in case... about nouveau, I tried it but it didn't work at all. –  WPBloyd Oct 15 '11 at 20:15
    
Good info, thats saves me the trouble of testing them ;) –  Bruno Pereira Oct 15 '11 at 20:16
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.