Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Just upgraded (reinstalled, because upgrading messed up my whole system) from 11.04 to 11.10 and Desktop sharing simply doesn't work anymore.

Under the Desktop Sharing Preferences I enabled the following options:

  • Allow other users to view your desktop
  • Allow other users to control your desktop
  • Require the user to enter this password (and set up one)
  • Show Notification Area Icon: Always

I set up the notification area icon to always show after I'd noticed my PC wasn't accepting VNC connections on port 5900.

After setting up the preferences like described above, imho the expected behavior would be a Desktop Sharing icon showing up next to the clock. The icon does not show and PC still not responding to VNC connections.

Any guidance appreciated.

Thiago

share|improve this question
add comment

2 Answers

Yep yep, it's not just you, it's an issue many are currently waking up to.

Somethings wrong with the Desktop Sharing in 11.10 ...

Here's some links to other threads working on that very issue. http://ubuntuforums.org/showthread.php?t=1861148 https://answers.launchpad.net/ubuntu/+question/174568

If your Internet connection uses a static IP address, then theres a workaround that seems to be working... oddly enough, just by changing to Dynamic in your ipv4 connection settings, rebooting, and then changing back to manual entry of your IP. It's a flaky workaround, but its working IF you use a static IP address.

(Right click on the network icon top-right, edit connections, click edit on your connection, under ipv4 change to dynamic or automatic whatever, save, restart, then change the settings back)

I however use a dynamically assigned IP address, and that workaround doesnt work for me. Ho-hum... hope they fix this soon... physically driving to work is starting to suck.

share|improve this answer
add comment

The only way I have seen to share (after you have done the above you mentioned in vino-preferences is that you need to have the person you want to share with in your Empathy messenger. After configuring vino-preferences you can use empathy to share. Already tested which is also the only way to enable sharing with Empathy. So it works both ways.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.