Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I used the sshfs app to mount a remote folder. The problem now is that I can't seem to share it. I can see all of it's contents when I directly do an ls and I also see it in the mount list when I run the mount command.

I mounted the folder on a folder I had shared (using samba) which I could see in my windows explorer (windows 7 64bit). I couldn't see the mounted folder after I mounted when I umount I can see it again.

I tried sharing the folder directly in the smb conf but it didn't do anything.

Can anyone help me out please?

EDIT:

I have done what JanC told me and I do see it know in the explorer window the only problem is I can't access it. It says I don't have permissions. Anyone?

share|improve this question
add comment

1 Answer 1

You must use the "allow_other" mount option for sshfs to make mounts visible to all users. If that doesn't fix the problem, you should probably give the mount options you use.

share|improve this answer
    
Thanks! This seems to have worked. I can see it in the windows explorer, but when I double click it it doesn't allow access. I have set in the smb.conf to allows guests but it still won't let me have access –  AntonioCS Oct 13 '10 at 7:11
    
You should probably check the ownership & permissions of the files you try to access... –  JanC Oct 14 '10 at 2:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.