Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

in 11.04 I can go to system->preferences ->startup applications and do things like uncheck Gnome Login Sound when I open Startup Applications in 11.10 the screen is empty

share|improve this question
    
Just curious... do you have at least ubuntu one or the updater there? –  alex Oct 15 '11 at 15:48
    
I have an ubuntu one account and I have run update manager –  Awm Lamp Oct 16 '11 at 18:02
add comment

3 Answers 3

The behavior I've discovered is the same as KDEs (local .desktops override system ones) so to be able to deselect/select items in 'Startup Applications' do this:

mkdir -p ~/.config/autostart # If not already created
cd ~/.config/autostart
cp /etc/xdg/autostart/*.desktop .
sed -i "s/NoDisplay=true/NoDisplay=false/g" *.desktop

Then pick your Startup Applications from the Startup Applications control panel. From there, "Log Out/Login" to apply (thanks to duffydack).

share|improve this answer
add comment

This may help you: http://maketecheasier.com/disable-login-sound-in-ubuntu-oneiric-quick-tips/2011/09/15

Apparently, .desktop files now have an option to not appear in the startup application preferences in 11.10. Setting this option to FALSE, makes this items appear in the startup preferences and then you can disable it.

EDIT: As Jo-Erlend Schinstad said, the link may not be available. So, I'll explain the idea here.

The solution is to change the .desktop file of the application you want to see in the startup preferences. For example, for the login sound, you have to open the file:

gksudo gedit /usr/share/gnome/autostart/libcanberra-login-sound.desktop

Then change the line that says

NoDisplay=true

to

NoDisplay=false
share|improve this answer
    
That is an external link, and that means it might go away without warning, making your answer useless. For that reason, it would be better to explain it in your answer. –  Jo-Erlend Schinstad Oct 15 '11 at 22:08
    
Thank you, the link provides a good solution for gnome sound and screen saver –  Awm Lamp Oct 16 '11 at 17:58
add comment

To enable them all again, run

find /etc/xdg/autostart/ -name "*.desktop" -exec sudo sed -i "s/NoDisplay=true/NoDisplay=false/g" '{}' \;

This will work but would only be temporary. For example:

dpkg -S /etc/xdg/autostart/ubuntuone-launch.desktop 
ubuntuone-client: /etc/xdg/autostart/ubuntuone-launch.desktop

So if ubuntuone-client gets updated it will disappear from 'Startup Applications'. A developer told me when I had a similar situation with KDE to first copy the .desktop file to ~/.kde4/share/kde4/services/ and edit it there (the local one will override the system one); be nice if Gnome had this too here.

share|improve this answer
    
Thank you for this elegant solution that replaces all the autostart options! –  Awm Lamp Oct 16 '11 at 17:59
    
thanks for the extra info regarding local overriding system, never knew that. –  duffydack Oct 16 '11 at 18:02
    
@AwmLamp Welcome to askubuntu, and remember to upvote good answers. –  belacqua Oct 18 '11 at 16:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.