Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have just upgraded to 11.10 but my MSi U130's touchpad doesn't work after login to 11.10. It works fine in the login screen where one types password to login. Thank you in advance.

share|improve this question
    
Is there an external mouse? And have you installed kde in the past? –  Reuben Swartz Oct 15 '11 at 15:42
    
Yes, I am using an external mouse, but don't want to carry around all the time. –  JTN Oct 22 '11 at 8:10
add comment

3 Answers

The problem could be caused by an IRQ conflict between your mouse and your touchpad. This is a Linux kernel bug (at least in 2.6.28) and as such it affects most distributions. An easy way to recover both mouse and touchpad functionality without having to restart your X server is restarting the mouse driver. Run the following commands in a terminal window:

sudo modprobe -r psmouse
sudo modprobe psmouse

source: Dealing with mouse and touchpad freezes in Linux

I am currently using Linux kernel 3.0.0-16, so if this is indeed the same bug, I'm surprised it's still there.

share|improve this answer
2  
What is this actually doing? Removing the overall mouse module or just the PS-2 mouse module? –  thegrinner Jan 27 '12 at 18:08
    
Bookmarked because this happens almost daily to me. –  Ian Hunter Jun 3 '12 at 5:50
add comment

Installing the synaptics utility and changig settings didn't work for me. I found something that fixed it in a [comment in a Bug report][1]:

  1. Install dconf-tools (dconf-tools in synaptic package manager or dconf Editor in the Ubuntu Software Center)

  2. Launch it, it's called "dconf Editor" (It's in the "System" group if you use filters)

  3. Find the setting "touchpad-enabled" in "/org/gnome/settings-daemon/peripherals/touchpad/" (See the pic below) and enable it.

  4. Quit the editor and you're done.

Note, this did not require a restart or logout/in for me, the touchpad started working straight away.

My laptop is an MSI i7 running 64 bit Ubuntu 11.10, upgraded from a clean install of ll.04

share|improve this answer
2  
I had to lick the "Set to default" button to make the change permanent. –  John T Dec 6 '11 at 10:59
add comment

The solution described here fixed this exact issue for me: http://www.myapitips.com/2011/10/14/touchpad-stopped-working-after-installing-ubuntu-11-10/

share|improve this answer
add comment

protected by Community Dec 16 '11 at 12:47

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.