Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How can I enable driver accelerated resolution to grub2? After installing proprietary NVIDIA driver my splash-screen resolution is changed to some lower value. Typing vbeinfo at grub2 command shell shows the supported resolution up to 1024x768x32 but my screen resolution is 1360x768. Can I enable this resolution somehow in grub2?

What i've found that grub2 screen supports the VBE supported resolutions only; as I've stated earlier 1360x768x32 is not listed in my vbeinfo o/p. So is that a no-go for me?

And is there any way to load nvidia module before Plymouth, it's still in fall-back mode, but on another PC intel's i915 module with i915.modeset=1 is working fine.

share|improve this question
    
Are you still looking for help with this or did you solve the problem? If you did find an answer please consider adding it here, thanks! –  coversnail Apr 7 '12 at 16:07
    
Actually I've not found the answer yet. My grub2 screen is still @ 1024x768x32. I've found that I can use those resolutions only which are supported by VESA Bios Extension(VBE),link; as vbeinfo clearly shows that 1360x768 is not supported I've quit trying :p, and my Plymouth screen is also @ 1024x768 and in fall-back mode, because proprietary nVIDIA drivers are incompatible with Kernel Mode Setting (link). So the usual <driver-module-name>.modeset=1 is not working too :( –  Samik Apr 15 '12 at 15:10
1  
If you add those comments as an edit to your original question it'll get bumped back to the first page and hopefully get more exposure and someone might be able to solve. –  coversnail Apr 15 '12 at 15:18
    
thanks, coversnail, edited it. –  Samik Apr 15 '12 at 15:35

1 Answer 1

up vote 1 down vote accepted

I think you are out of luck, I'm afraid.

Grub2 is started by BIOS before a kernel is loaded and BIOS is used to display its graphics. After you make a selection Grub loads the kernel and then the kernel loads a graphics driver. But while Grub is running the tools it has available are sort of primitive compared to what you have later. It doesn't know how to communicate with a (fancy, powerful) graphics driver and there's not room in Grub to get very fancy itself. Grub2 fits in about a 31K area, if I'm not mistaken.

While it is started by the kernel, Plymouth is started rather early as well, in order to get the splash screen up quite quickly so the user can be assured that something is happening. While it runs the kernel explores the system for its various devices and starts various things up. For non kms drivers, if I recall correctly, most of the proprietary graphics driver is loaded by X, which is itself started just before you see a login screen, too late to do you any good with Plymouth, I'm sorry to say.

share|improve this answer
    
Thanks for the answer, John. I understand your simple explanation for GRUB and Plymouth. I think that is the source of the problem that while KMS-compatible graphics drivers like Intel i915 can be loaded before Plymouth, the non-KMS ones like nVidia can't be. And I've switched to BURG, though it does not provide nested menus and the desired resolution, it's prettier :). –  Samik May 26 '12 at 10:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.