Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

my wireless is not working in Ubuntu 11.10 and it worked fine in 11.04, i've done a fresh install and it detects the wireless but when i try to connect it keeps asking for the WPA key.Can anyone help me? I've tried to download the drivers from the realtek site but i get an error when i do "sudo make" i'm using a 64bit and i've tried the 32bit and nothing solves the problem.

my wireless card: RTL8191SEvB

share|improve this question
    
Connecting to an unprotected wireless network fails too, but connecting through Bluetooth and my phone's 3G does work, the problem seems to be in the wireless drivers malfunctioning somehow. I can find all the wireless networks and such, but trying to connect just makes the icon in the top left corner blinking and after a minute or so it either disconnects or asks for the password again. Setting the password in the network manager by editing the network info doesn't help either. I hope they patch this bug soon... 3G just isn't enough :S –  user27709 Oct 15 '11 at 21:10
add comment

2 Answers

You have to compile the driver.

Download the latest Linux driver from Realtek. Choose the Linux driver for kernel 2.6.35 and above.

Install a few dependencies

sudo apt-get install build-essential

Extract all files. In a terminal, execute the following commands:

cd into the extracted directory
make
sudo make install
sudo modprobe rtl8192se

Wifi should be working now. In order to keep the wifi working after a reboot, add one line with "rtl8192se" to the /etc/modules file.

gksudo gedit /etc/modules

Modified from http://michael-peeters.blogspot.com/2011/10/fixing-rtl8191se-wifi-under-ubuntu-1110.html

share|improve this answer
add comment

The "WPA key" is the password protecting your network. Your previous version (11.04) must have been set up to automatically enter the password. All you need to do is enter the password and set Ubuntu up to login automatically.

If you do not remember the password, you will have to connect to the router through an ethernet cable and change the password from there.

I switched too from 11.04 to 11.10. The new (Huawei 173) surfstick did not work. What I did: I reinstalled the usb-modeswitch (these are two (by default installed) apps). Then - after waitung a minute or so -- it started working (first asking for the pin).

share|improve this answer
    
thanks i've reset my WPA key in the router and entered it but it dont connects and keeps asking for the WPA key wich i've reset to a new one –  Carlos Reis Oct 15 '11 at 14:32
    
Is the router set up with the exact same password you are entering? –  Trevor Oct 15 '11 at 14:34
    
yes, i check it twice, and i've done a copy paste and nothing worked –  Carlos Reis Oct 15 '11 at 14:58
    
Have you made sure both the router and your wireless card are set up for the same encryption? (WPA or WPA2-much better by the way) –  Trevor Oct 15 '11 at 15:06
    
WPA & WPA2 Personal on both –  Carlos Reis Oct 15 '11 at 15:08
show 7 more comments

protected by Oli Oct 15 '11 at 23:06

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.