Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

mediatomb works fine when starting manually but the autostart doesn't work. In the wiki it says it should start automatically at system start, but it doesn't. tryed many things but still doesn't work any ideas??

share|improve this question
When I figure this out, I will answer your question. It might take a week or more before I get some time to sit down with it. I'm having the same issue on Ubuntu 11.10. – djangofan Dec 7 '11 at 17:51

From my own experience, you should first configure it to your liking using your own account and testing it manually from the command line.

When you have everything set up, you should copy your ~/.mediatomb/config.xml file to the global localtion (which is read by the mediatomb service during startup) /etc/mediatomb/config.xml.

I'm not sure, but you might have to fix permissions so mediatomb can read (write?) from your home folder or wherever your media files are.

share|improve this answer
This answer didn't work for me. My mediatomb works fine when I run it from my logged-in session. But, when I restart my server, even though mediatomb is a service within /etc/init.d/rc3.d , the server fails to start. – djangofan Dec 7 '11 at 17:50

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.