Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Earlier today, I installed Pantheon Shell, and got an unpleasant surprise. My wallpaper doesn't work! It doesn't work in either Pantheon, Gnome 3 Fallback, and Unity 2D. Instead, the background is gray, and I can't get rid of it. What do I do?

share|improve this question

2 Answers 2

A possible fix is:

  1. Install dconf-tools sudo apt-get install dconf-tools)
  2. Open dconf-editor
  3. Navigate to: desktop -> wallpaper -> picture path.
  4. Type/paste the path to your wallpaper and press enter.

This should fix the problem.

share|improve this answer
    
Since I am new to Ubuntu, I have no idea how the dconf editor works (which I downloaded) and what a wallpaper path is. Please try to make it easier to understand. –  Schism430 Oct 15 '11 at 15:01
    
if you drag a file into a terminal window it will tell you the path to the file inside two ' –  Alvar Oct 15 '11 at 15:12
    
Ok, I figured it out, but inside "Desktop", "Wallpaper" does not exist. I suppose in needs to be reinstalled somehow. –  Schism430 Oct 15 '11 at 15:28
    
The pantheon-wallpaper app is probably running in Gnome3-Fallback and Unity2D. If so: type killall pantheon-wallpaper in a terminal. this does not work in Pantheon itself... –  Jonathan Oct 15 '11 at 15:47
    
@Jonathan: Here is my response once I did that - "pantheon-wallpaper: no process found" –  Schism430 Oct 15 '11 at 19:31

I had the same problem recently. I uninstalled all pantheon apps and the problem persisted, then I disabled and re-enabled draw-background in org/gnome/desktop/background with dconf-editor and voila, my wallpaper showed up. Hope this helps!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.