Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

It shows only one workspace when I click on workspaces icon, what should I do?

share|improve this question
1  
Is this a fresh install? If this happens in a fresh install then it is surely a bug –  Manish Sinha Oct 15 '11 at 13:20
    
has this problem been solved? Can you confirm? –  Manish Sinha Oct 22 '11 at 22:22

2 Answers 2

up vote 6 down vote accepted

Get Compiz Config Settings Manager

Install the package compizconfig-settings-manager install ccsm

Via Command Line:

sudo apt-get install compizconfig-settings-manager

Via Software Center:

Or you can install it via Software Center. Open Dash and type software which will show Software Center

Opening Software Center via Unity Dash

When Software Center is opened then search for compiz on the top-right hand side

Searching for ccsm in Software Center

In my case it shows Remove since I have it installed. In yours it will show Install. Just go ahead and install it. If a password is asked, enter the password you use to login to Ubuntu.

Open Compiz Config Settings Manager or ccsm

Then open Dash and search for ccsm

How to open ccsm from Unity Dash

After CCSM has opened.

enter image description here

Select General Options. It is in the second row

After you click on General options, select the last tab named Desktop Size

enter image description here

Now check the Horizontal Virtual Size and Vertical Virtual Size

In my case both are 2, so I have 4 workplaces 2X2

In your case it would be 1. Increment and make it 2 and then click on Launcher > Workplaces icon. The changes should be reflected

share|improve this answer

I have this problem after upgrading from 11.04 to 11.10 and compiz settings don't reflect even after rebooting. I had 5 workspaces before upgrading, now I have just one :(

This method works for me: How do I get multiple workspaces in Unity?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.