Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Im using a an Acer Aspire Revo R1600 and for some odd reason with this new version of Ubuntu i can't play .MKV files anywhere. I have always had flawless playback but now im getting a weird message from the video player.

"Could not find GStreamer caps mapping for FFmpeg codec 'h264', and you are using an external libavcodec. This is most likely due to a packaging problem and/or libavcodec having been upgraded to a version that is not compatible with this version of gstreamer-ffmpeg. Make sure your gstreamer-ffmpeg and libavcodec packages come from the same source/repository."

I tried installing the restricted extras and playing it back in VLC but in VLC i just get a green picture and thats all.

share|improve this question
Installing ubuntu-restricted-extras and running vlc was all I ever needed to do. – Abhay Rana Oct 16 '11 at 0:27
up vote 0 down vote accepted

try reinstalling the gstreamer plugins

share|improve this answer
how does one do this? I tried apt-get remove gstreamer0.10-plugins- and then install them again, but this didn't solve the issue. – axel22 May 31 '12 at 19:30
this does not solves the issue.. video plays fine in VLC and but in TOTEM it is giving this error. – AurA Apr 14 '13 at 16:17

Thanks for everyones advice, basically what was going on is that the video that i was trying to open was toooooo biigggg for my computer to handle (resolution) im running a 1.6 Intel Atom Processor, and apparently i can't do 1080p so basically it was an internal codec error cause my processor could process the video, thanks anyways guys

share|improve this answer

That is incorrect. This error is related to bug #879066. Whether your computer can actually handle the file you are trying to play or not is unrelated.

share|improve this answer

Agreed with @NCLI. I ran into this problem when playing an MKV file that was encoded with 10 bit codec.

I installed mplayer2/smplayer from this repository and then viewing it in smplayer worked.

Here's a quick video showing the istallation steps and a sample 10 bit encoded video viewed

share|improve this answer

protected by Community Oct 29 '11 at 23:17

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.