Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So my wi-fi card is a Intel 5100 AGN and so far doesnt works. if anyone managed to make it work give me any hint. Ubuntu user :) tried disabling ipv6 - no result

share|improve this question
    
helloooo?! @Jorge Castro, re-edit a bit the title of question :) –  zippy Oct 16 '11 at 16:19
    
Maybe related: askubuntu.com/questions/79721/… –  mogsie Feb 29 '12 at 0:11
add comment

5 Answers 5

There is a problem with kernel 3.0.0.x and Intel wifi under 802.11n.

We are all waiting for the fix in the kernel.

There is a workaround:

  1. Create a file /etc/modprobe.d/intel_11n_disable.conf containing :

    options iwlagn 11n_disable=1
    
  2. sudo update-initramfs -u

  3. reboot or sudo modprobe -r iwlagn && sudo modprobe iwlagn

Ref:

share|improve this answer
    
This worked for me! Thanks! Asus u52f with 02:00.0 Network controller: Intel Corporation Centrino Advanced-N + WiMAX 6250 (rev 5f) –  Fitoria Oct 30 '11 at 3:35
    
It's still not fixed in kernel 3.3-precise. This workaround works like a charm. –  Hakan Deryal Mar 24 '12 at 11:16
    
worked for me too. Lost wireless after upgrade to 11.10. –  Pete Apr 9 '12 at 0:09
add comment

Note that for 12.04 and later, you need to replace all references of iwlagn with iwlwifi (at least, according to what I've read). That's what worked for me with my Intel Pro Wireless 5100 on 13.04.

  1. Create a file /etc/modprobe.d/intel_11n_disable.conf containing:

    options iwlwifi 11n_disable=1
    
  2. sudo update-initramfs -u
  3. reboot

(other answers say to run modprobe, but it always said my wifi was in use, even when disabled, so reboot was required for me)

share|improve this answer
add comment

Did disable via options iwlagn 11n_disable=1

After a kernel update to 3.0.0.13-generic i tried to set

options iwlagn 11n_disable=0

This did enable N speed without the reappearance of the lost and slow connections or dead dd-wrt access points.

share|improve this answer
add comment

Update: Since I got downvoted, I changed the answer a bit:

  1. Backup the .deb files, just in case:

    sudo apt-get download network-manager network-manager-gnome
    

This will download two .deb package files in your home directory

  1. Purge network manager and install wicd

    sudo apt-get purge network-manager network-manager-gnome
    sudo apt-get install wicd wicd-gtk
    
  2. Reboot. Try to connect using wicd.

If anything goes wrong, just purge wicd and reinstall network manager:

sudo apt-get purge wicd wicd-gtk
sudo dpkg -i network-manager*.deb
share|improve this answer
add comment

This :

There is a problem with kernel 3.0.0.x and Intel wifi under 802.11n. We are all waiting for the fix in the kernel. There is a workaround:

  1. Create a file /etc/modprobe.d/intel_11n_disable.conf containing :

    options iwlagn 11n_disable=1

  2. sudo update-initramfs -u

  3. reboot or sudo modprobe -r iwlagn && sudo modprobe iwlagn

Ref: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/871254

works for me, EXCEPT that I need to do it every time I reboot :(

I wrote a script to spare me a bit of pain but I'd be SO grateful if someone could tell me why it's not persistent and mainly how to make it persistent!

Thanks everybody!

P.S. : my wifi controller details:

$ lspci -v
...
08:00.0 Network controller: Intel Corporation WiFi Link 5100
        Subsystem: Intel Corporation WiFi Link 5100 AGN
        Flags: bus master, fast devsel, latency 0, IRQ 45
        Memory at c0300000 (64-bit, non-prefetchable) [size=8K]
        Capabilities: <access denied>
        Kernel driver in use: iwlwifi
        Kernel modules: iwlwifi
...
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.