Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When we run an application, its icon would appear on the launcher and so we can call it back after minimize it. Specially, a little triangle would keep appearing near the icon, meaning this application is running now.

However, when I open a Libreoffice file, the revelance icon doesn't appear on the launcher! What's more, when I minimize Libreoffice, I couldn't find it even through "Alt+Tab". I've tried Libreoffice 3.4 and 3.3, but the problem exists all the same.

Look, here is Libreoffice Calc running, and no icon appears on the launcher. If I minimize it, it is impossible to call it back.

enter image description here

share|improve this question
Can you upload them now? It's hard to tell what this question is about without screeshots. :) – James Oct 15 '11 at 12:09
It would also help if you told us the User Interface. Is it Unity 3D or 2D or Gnome shell. – grahammechanical Oct 15 '11 at 12:13
Can you Upload them now? – Amith KK Oct 15 '11 at 12:16
I'm using Ubuntu 11.10, unity 3D. Only unity has launcher, gnome shell has no launcher – billzt Oct 15 '11 at 12:20
Thanks for adding a screenshot! In order to help you with this best, can you join us in the chatroom? :) – James Oct 15 '11 at 12:30

You can use Super+W to show all the windows on your desktop. The LibreCalc window will appear there.

(The Super key is often the Windows logo).

There is a problem, but this is a work-around.

share|improve this answer
I have the same problem and this workaround unfortunately doesn't work. – ej159 Nov 30 '12 at 17:20

Logout, then log back in again using Unity 2D, then log back out and back in with 3D. Your problem should be solved.

Theories as to why it does this include.

  • Unity 2D launcher config overwrote the Unity 3D config, thus "fixing" the configuration files.

  • Unity 3D was having a bad day and needed a break.

share|improve this answer
I am having this same issue and tried your suggestion to no avail. – Nicholas Mancuso Nov 7 '11 at 16:05
@NicholasMancuso tried a unity --reset? note: that will reset your unity config – James Nov 7 '11 at 16:08
This solution does not work. – zoopster Nov 8 '11 at 19:08
@zoopster At the time when I was attempting to debug it, this was the solution that worked for the OP.. If that isn't the correct solution, then I'm sorry - you must have a different problem, or the OP did something that I wasn't told about. – James Nov 8 '11 at 19:10
unity --reset works, but there is something in unity that is corrupting the configuration. There are several bugs opened in LP against it...seems the Unity team is trying to figure it out, but it is not reproducible with consistency. @jrg I would imagine (but cannot confirm) that a switch might reset the config temporarily, but it's not a workable solution. – zoopster Nov 8 '11 at 19:20

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.