Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In Natty I had my keyboard shortcuts configured to use most of the numbers on the numerical pad on the right side of my keyboard, e.g. 8 turned volume up, 2 down, 4 previous track, 6 next track, 1 play/pause and 0 to launch default media player. Since I installed Oneric I went into keyboard shortcuts and set them all to the same keys but now none of them work, any ideas why? I've also tried using Number Lock but that hasnt worked either.

share|improve this question
add comment

1 Answer

I did some testing and found that I have the same problem. I'm guessing you can't do one-key shortcuts because most keys have a default function (such as num-pad 9 being page-up) and those functions probably overwrite all other user-defined functions. This can be seen if you set a custom shortcut, activated by key-pad 9 (should be seen as Page up (keypad) with num-lock off); when pressed, it will either (seemingly) do nothing or, if your selection is not at the top of the list, it will move it up (i.e. using its default function).

However, you can still use those keys for shortcuts, but you will need to start the combination with something else (such as ctrl, alt, or shift).

Note: the shortcut will not work if you have num-lock enabled (I'm not exactly sure why this is, though... maybe because it conflicts with the normal [i.e. non-num-pad] numbers).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.