Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Sometimes when I insert an audio CD I get a dialog that says "You have just inserted an Audio CD. Choose what application to launch." It doesn't show up for every CD... probably something like once for every 5 CD insertions.

Every single time I select "Do Nothing" and ensure that the "Always perform this action" checkbox is checked. I assume the point of the checkbox is to let me make the decision once and for all, but this dialog continues to reappear periodically.

share|improve this question
3  
And as if to taunt me, now when the dialog appears "Do Nothing" is selected and "Always perform this action" is already checked! Where's the "What part of 'Always' don't you understand?" button? –  Laurence Gonsalves Oct 13 '10 at 4:36
add comment

2 Answers 2

up vote 4 down vote accepted

Prompting for action to perform upon inserting media is a behaviour of nautilus (the file browser program in GNOME Environment). To change this behaviour I would recommend the following steps:

  1. Close all open File Browser windows
  2. Open Places -> Home Folder. This will open the home folder in a new File Browser window.
  3. Click Edit -> Preferences
  4. Select the Media tab
  5. For those media types where you don't want any prompt, select Do Nothing in the drop-down list.
  6. Click Close

From next time, you should not get the messages while inserting media.

share|improve this answer
    
I went there and "Do Nothing" was already selected for CD Audio, DVD Video, Music Player, Photos and "Other Media/audio DVD". –  Laurence Gonsalves Oct 13 '10 at 16:20
    
... and you still get this dialog once in a while ? –  koushik Oct 14 '10 at 7:50
    
I haven't tested (yet), but why would opening a settings dialog and then dismissing it without changing anything cause the behavior to change? –  Laurence Gonsalves Oct 16 '10 at 0:59
    
Strangely, I have not seen the dialog appear again. That opening a settings dialog and then dismissing it without changing anything would actually alter the behavior seems like a bug, but at least it appears to solve my problem. Thanks. –  Laurence Gonsalves Oct 22 '10 at 18:59
    
FWIW: I filed a bug about this: bugs.launchpad.net/ubuntu/+source/nautilus/+bug/665297 –  Laurence Gonsalves Oct 22 '10 at 19:12
show 1 more comment

In 12.04 this functionality is no longer in Nautilus and has been moved to the System Settings application.

Unity Dash -> System Settings -> System -> Details -> Removable Media

There is a checkbox there that says "Never prompt or start programs on media insertion"
I haven't tested if it actually works though ;-)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.