Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In my laptop the sound code is running at 100% even when I am not playing anything. It is causing my palm rest to hit significantly. While I do not face the issue on windows machine where I am using the drivers for IDT. Here is the output of the powertop.

Summary: 0.0 wakeups/second, 0.0 GPU ops/second and 0.0 VFS ops/sec

            Usage       Events/s    Category       Description
        100.0%                      Device         Audio codec hwC0D0: IDT
         52.3 ms/s       0.0        Process        compiz

Is there any solution to decrease the power consumption of the sound device.

share|improve this question
    
This question appears to be abandoned, if you are experiencing a similar issue please ask a new question with details pertaining to your problem. If you feel this question is not abandoned, please flag the question explaining that. :) –  Ringtail Feb 26 '12 at 23:00
    
Hello Guys, I have resolved all of power issues in my Ubuntu system using tlp. If anyone facing similar issue I will suggest to check out that utility. –  Abhijeet Sep 28 '12 at 15:52
add comment

3 Answers 3

I added the following to /etc/rc.local

echo 1 | tee /sys/module/snd_hda_intel/parameters/power_save

echo Y | tee /sys/module/snd_hda_intel/parameters/power_save_controller

pkill pulseaudio

pulseaudio --start 

exit 0

And it seems to have done the trick...

share|improve this answer
    
This turns the pulseaudio process on Ubuntu 12.04 from the permanent >50% down to 0% in powertop. Thanks! –  Ferdinand Prantl Jan 7 at 12:06
add comment

Either the sound driver doesn't support power management or it's not enabled. I've no idea what IDT is, but you can enable power management, for example, for an Intel sound device. The older versions of PowerTop used to suggest it, but the newer one has a menu you can navigate with left/right arrow key - Tunables is the entry you want. Try navigating to that entry and see if there is anything related to the sound card that powertop can tune.

share|improve this answer
    
Thanks mikewhatever. I have tried that options in powertop but that setting is not persistent on reboots. Even on manually setting the low using powertop, Audio codec is at 100% usage. I just left Ubuntu on laptop becuz all these heating issues. Literally you can fry an egg on my laptop palm rest, while on windows it is super cool. –  Abhijeet Oct 17 '11 at 5:40
    
The heating issues are troubling indeed. Have you tried the pcie_aspm=force kernel option? If you want to troubleshoot it further, add some hardware specs to the original question. –  mikewhatever Oct 17 '11 at 15:16
add comment

I am also affected by this issue on debian may those urls help to investigate :

https://bugs.launchpad.net/ubuntu/+source/powertop/+bug/536631

http://rzr.online.fr/q/lenovo

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.