Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
Unity doesn't load, no Launcher, no Dash appears

What I did:

In a fresh setup of 11.10, I used compizconfig-settings-manager as explained in this question to change the icon size of the Unity launcher.

What happened:

As soon as I did this, the application froze and the launcher disappeared. I thought, well, maybe Unity crashed, so I logged out with Ctrl-Alt-Del, and logged in again.

Unity still does not appear anymore. I am just left with my desktop background and Nautilus running. I can open a new Nautilus window, and browse my file system, but that's about it.

What works:

I can log into Unity 2D, only the "normal" Unity does not work.

So, how do I get Unity back? Is there any way to reset the configuration, or look for some more detailed error messages?


What I already tried:

  • Starting a Terminal and running unity --reset. It's stuck at "Initializing session options … done", and nothing else happens.
  • Starting a Terminal and running unity --replace. Same as above.
  • From the 2D mode, calling unity --replace or -- reset. It hangs after "Starting unity-window-decorator", and if I abort the process, my keyboard input is disabled.
share|improve this question

marked as duplicate by jrg Feb 23 '12 at 14:59

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

5 Answers 5

up vote 11 down vote accepted

I'm pretty sure I had the same problem as you.

What I did to fix it was open a Terminal (Ctrl-Alt-T), type ccsm install ccsm in the Terminal and then enabled the Ubuntu Unity plugin and it now works again.

share|improve this answer
    
This is exactly it. It gave me a message about resolving conflicts, but I ignored and skipped it. Seems to work for now! –  slhck Oct 15 '11 at 20:59
    
Talk about conflicts. There are about 7 key bindings that conflict with unity's settings. –  Ritesh M Nayak Oct 30 '11 at 11:30

I had the same problem but none of the solutions explained here works.

Here is how I solved my Unity launcher problem:

  • Open a terminal with Ctrl+Alt+T
  • Open the compizconfig-settings-manager with this command : ccsm (if it's not installed, use sudo apt-get install compizconfig-settings-manager)
  • Click on the category: Desktop
  • Marked Ubuntu Unity Plugin and answer to all the conflict key you may have
  • Unity Launcher is back!
share|improve this answer
    
> none of the solutions explained here works – yes, of course. The one I marked as accepted. Type ccsm in the terminal and tick the Ubuntu Unity Plugin. Also, please check your formatting, <pre> is only used for code. –  slhck Oct 19 '11 at 8:03

Try running unity --reset from a terminal.

share|improve this answer
    
I can do this in Unity 2D terminal, but that doesn't help. I went to /usr/bin/X11/xterm and entered the above command, but it's stuck at Initializing session options … done. –  slhck Oct 15 '11 at 10:14
    
That's strange... Output of /usr/lib/nux/unity_support_test -p? –  RobinJ Oct 15 '11 at 10:49
    
All positive... –  slhck Oct 15 '11 at 10:57

Try running unity --reset (or unity --replace or both) from the 2D environment and restart the computer afterwards. I've had the same problem and it worked for me.

share|improve this answer
    
No luck either. It hangs at "starting unity-window-decorator", and if I abort the process then, my keyboard stops working, and nothing is really fixed. –  slhck Oct 15 '11 at 20:37

I had this problem..

I logged in to the Gnome shell ran the compiz Configuration utility and found out that the unity component was disabled ( of course I did not do it ) but I re-enabled it , solved a few conflicts and rebooted I logged in to Unity and every thing worked fine

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.