Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently upgraded to Oneric and found that Fn+F8 does not switch displays on Oneric, Dell E6410, Nvidia. I frequently run presentations and need to switch between projector and laptop with minimum fuss, so this key is important to me!

In Maverick, I managed to make it work using acpi_osi=\\\"!Windows 2009\\\" in grub (as described here: http://www.len.ro/2011/01/e6410-summary/). It's a bit shameful to go into a room of people, plug the laptop and wait 5 minutes to make the change using nvidia-settings. How can I make the Fn+F8 work again?

After a bit of debuging with xev it seems that the acpi_osi has some effect but the videoswitch does not take place somewhere else even if /var/log/XOrg.0.log shows:

[ 24182.812] (II) PM Event received: Capability Changed

Maybe there is some other place where the event is not handled correctly.

share|improve this question
    
Try going to the system/power cog and clicking displays. From there you can switch your displays quickly. –  William Nov 6 '11 at 22:48
    
William, I think this does not work if using the Nvidia driver; in that case you have to use nvidia-settings. disper and the disper-indicator could be a viable workaround, that's what I do. –  Christoph Nov 9 '11 at 15:13
add comment

3 Answers 3

Finally I gave up and decided to adopt the simpler solution of using disper.

apt-add-repository ppa:disper-dev/ppa
apt-get update
apt-get install disper

and then

disper -c to switch to external monitor and disper -s to return to main screen. I also configured a shortcut in xfce which I now use to map p to disper -c

share|improve this answer
add comment

Better solution for me seems to be to switch external display on/off using nvidia-settings, where it is possible to detect resolution of external display and switch the TwinView feature on and off (as well as other helpful configuration options).

share|improve this answer
add comment

Did it work in Windows? It may be that you are using the wrong key. Also, try using other keys (eg Fn+F5, Fn+F9, etc)

share|improve this answer
    
its clear that the user knows what key to use and they were working before the upgrade. –  Bruno Pereira Nov 10 '11 at 11:17
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.