Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My question is similar to this, but now it is about 11.10.

My wireless card:

~$ lspci -vvnn |grep 14e4
03:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller [14e4:4727] (rev 01)
    Subsystem: Broadcom Corporation Device [14e4:0510]

I followed the instructions on the Ubuntu Wiki and reinstalled my STA driver but still no luck.

I also removed and reinstalled the driver and nothing changed. I am tired rebooting :).

More info:

~$ sudo lshw -class network
  *-network               
       description: Ethernet interface
       product: AR8131 Gigabit Ethernet
       vendor: Atheros Communications
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: eth1
       version: c0
       serial: 5c:ff:35:0f:bd:8b
       size: 100Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vpd bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=atl1c driverversion=1.0.1.0-NAPI duplex=full firmware=N/A ip=192.168.0.106 latency=0 link=yes multicast=yes port=twisted pair speed=100Mbit/s
       resources: irq:43 memory:d0200000-d023ffff ioport:a000(size=128)
  *-network
       description: Network controller
       product: BCM4313 802.11b/g/n Wireless LAN Controller
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:03:00.0
       version: 01
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: driver=bcma-pci-bridge latency=0
       resources: irq:17 memory:d0300000-d0303fff

~$ rfkill list
0: ideapad_wlan: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: ideapad_bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no
2: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
share|improve this question

1 Answer 1

up vote 1 down vote accepted

Unfortunately the driver worked ONLY after fresh install and blacklisting acer_wmi. I just added "blacklist acer_wmi" to the end of the file. /etc/modprobe.d/blacklist.conf

Seems upgrading does not perform enough cleanly.

Well if you find your self doing like me, you can keep your current settings and user files by installing the system in "/"and formatting it but keeping your "/home" partition intact. You just need to enter the same username when you create your first(default) user. If you have more users name them as they were and create them (including the first) in the same order they were created in previously.

Hope this helps someone.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.