Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

What i can do for this? I have so damn laggy and bad performance with Ubuntu 11.10 and Unity like with 11.04. ATI Drivers installed, and Sync to VBlank is disabled. I really want to use Unity, but its so laggy.

share|improve this question

3 Answers 3

Try selecting Unity2d at the login screen. Visually, Unity and Unity2d are very similar, but Unity2d is not based on Compiz, so it may perform better.

share|improve this answer
    
Yes, Unity 2D works OK but i would like to use normal Unity.. What is wrong with Unity because it has bad peformance with ATI? –  asdasdasdasdad Oct 16 '11 at 10:11

I have an HD 4250. The problem is fixed by installing the proprietary driver.

share|improve this answer
    
Isn't the ATI driver proprietary? –  Nathan Osman Oct 17 '11 at 6:20

I believe I have got some of the same problems with HD 4890 which runs poorly on Unity 3d as well with the latest propietary driver from ATI. When I had nVidia I only had to tweak compiz by editing the framerate settings in compiz settings manager found with synaptic, but this doesn't do anything for me with ATI, so I am also looking for a solution. "glxgears" caps by 60 fps, but still the animation looks incredibly laggy compared to earlier Ubuntu's which was about 14-15000 fps. So what's going on?

Okay I got a "fix" for my own case, which could help you as well. I installed compiz settings manager and messed around with openGL plugin (texture filtering etc.) and got great performance after a reboot. Now I have no issues what so ever and I am even running 3d-accelerated virtualbox and hardware-acc flashplayer atm. Good luck!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.