Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I started the upgrade from 11.04 to 11.10 last night. Once it got the installing packages part I left the computer unattended the rest of the night. When I checked it this morning the screen was blank and I couldn't get it to turn on. So I cycled power, and now I get the "Ubuntu 11.10" screen with the dots underneath, but then it gets to a blank screen and nothing more. I can get to the command line in recovery mode; here's a list of the things I've tried so far

  • sudo apt-get update - the very first repository it checked sat at 0% for a long time (network cable is plugged in), so I cancelled with Ctrl+C
  • Thought it might be a problem with display drivers, so I tried sudo apt-get install nvidia-glx - this gave me an error saying dpkg has been interrupted, manually run sudo dpkg --configure -a
  • sudo dpkg --configure -a this installed / updated a bunch of stuff but got stuck at Starting Winbind daemon winbind
  • Restarted and tried sudo dpkg --configure -a again but it gets stuck at same Windbind step

What else can I do to fix this problem?

share|improve this question
up vote 4 down vote accepted

You might want to try sudo dpkg --purge winbind to completely remove it first (this package is a part of samba Install samba which facilitates sharing files over a network with machines running Windows). You can reinstall the package later if you wish.

share|improve this answer
Thanks! After purging winbind I ran sudo dpkg --configure -a again and it completed successfully. I was then able to boot into Ubuntu normally. – Praetorian Oct 16 '11 at 2:16


sudo dpkg --purge winbind

does not resolve whether 'winbind' should be still installed.

Problem may re-occur, if user again installs winbind (used by Samba).

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.