Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've found that after upgrading to 11.10 (32 bit), I can no longer watch streaming flash video on sites such as Ustream or I've spent the last several hours installing this package and uninstalling that package, and purging everything flash-related and starting over, to no avail. I was curious if anybody else has run into similar issues and found a fix.

I'm running an NVIDIA card, and I've tried both sets of drivers available.

share|improve this question
I think it's particularly pathetic that an upgrade of Ubuntu (nowaways) still manages to break flash support. – levesque Oct 15 '11 at 4:52

I got tired of the adobe-flashplugin package failing on me so I did it manually.

Download the flash plugin from the adobe website. Pick the 64 bit, .tar.gz version. Take the file from that archive and move it:

sudo mv /usr/lib/mozilla/plugins.

Make sure it is executable:

sudo chmod +x /usr/lib/mozilla/plugins/

Screw the buggy installers.

Pros : It's gonna work.

Cons : It won't update automatically.

share|improve this answer

Go to firefox ads on (Edit -> preferences -> manage ads on) and then install plugin flash-aid. Install stable flash version instead of beta. It worked for me.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.