Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed Ubuntu 11.10 in my laptop.The network I am connected to uses a proxy server. I adjusted the proxy settings in System Settings->Network->Network Proxy.

I applied them system wide, but in Google Chrome it is not working. I am unable to browse although I can access the Internet through Mozilla Firefox where I set up the proxy manually.

Can any one tell me what the problem is? How I can correct it?

share|improve this question
    
have you tried proxy anywhere extension? chrome.google.com/webstore/detail/… –  duffydack Oct 17 '11 at 20:34
    
this might help. –  green7 Mar 10 '13 at 18:37

5 Answers 5

One method of bypassing this problem is to install the Switch Proxy extension for Chromium, then set your proxy settings within the extension. Chromium will pay attention to these extension settings.

share|improve this answer

There are lots of possible reasons. Try the following:

  1. Update Chrome (Run a normal software update)
  2. Use Proxy Switchy Chrome Extension
  3. Try using Chromium, as I can confirm that it uses the correct Proxy settings.

Also see this bug report for further details.

As a workaround, you can try out these steps (from here):

  1. Install the gconf-editor package.
  2. Start the Configuration Editor application
  3. Go to the system -> proxy tab and set the proxy you want there.

Make sure you set the mode value from ‘none’ to manual , and for example if you want to set a socks5 proxy set the socks_host and socks_port values.

This workaround is for the case when you have an older version of Chrome, which uses gnome2 proxy settings.

share|improve this answer
    
I am actually having the issues with Chromium –  Shane Dec 12 '13 at 1:13

Download `dconf-tools :

sudo apt-get install dconf-tools

run it from terminal:

dconf-editor

Then go to "systerm>proxy" change "mode" to manual and select "use-same-proxy" now goto "system>proxy>http" give your proxy information there and select "enable" option

make sure ftp, https and socks have "0" (zero) on "port" and nothing on "Host" field

Everything should work fine now.

share|improve this answer
    
For Unity, use All Settings > Network > Network Proxy for configuring system-wide proxy. –  Amir Ali Akbari Apr 16 at 14:55

I have spent ages trying to find an answer to this horrible problem, without result. Every time I close Chrome, or re-boot my computer the next time I open Chrome that evil proxy setting has changed. I have e-mailed Chrome technical help but they don't reply.

But I have found a solution. As Chrome says, go to settings, show advanced settings, proxy settings, change proxy settings, LAN settings, and un tick 'use proxy server ...'

But now, the key thing is, do not close these last 2 little windows. Leave them open. As long as they are open that effing malware virus does not activate. You can continue with Chrome without proxy problem. Until, that is, you close those little windows or re-boot the computer. In which case you have to go through the process again. In other words, so long as you keep those little windows open you won't have a proxy problem.

I Hate Chrome for not having found a better solution for this yet.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.