Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just recently installed Ubuntu Desktop 11.10 on my laptop.

The laptop is a Toshiba Satellite m645. It does not have a Bluetooth radio in it so I plugged in an IO gear USB Bluetooth adapter. The model is GBU421 and upon further inquiry I found out that the radio is a Broadcomm BCM2046b1.

I have discovered that lsusb shows the radio as being found in the computer - but the Gnome Bluetooth manager says that there is nothing there. So I am guessing it is a problem with Gnome Bluetooth manager not with Linux in general.

Is there anything I can try in order to make this work?

share|improve this question
up vote 3 down vote accepted

I would strongly suggest installing blueman Install blueman - which is a Bluetooth manager with a lot of options and, in my experience, much better support for devices.

You can install the tool by clicking the little package icon in the above paragraph or opening a terminal and typing:

sudo apt-get install blueman

share|improve this answer
I tried that, but that does not solve my problem. My problem seems to be related to the bluetooth radio. Not the management of it. – ianc1215 Oct 15 '11 at 0:39
I stand corrected!, blueman did the trick. Turns out the problem was something to do with the Windows driver disabling the device. Plugged it in, re enabled the device then plugged it back in. Now it works great. Where blueman helped me was when it came to A2DP, the Ubuntu tool did not allow me to run in A2DP mode, blueman did. Thanks a lot. – ianc1215 Oct 21 '11 at 6:11
@Solignis: No problem! Glad that your Bluetooth adapter is working now. – Nathan Osman Oct 21 '11 at 6:24

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.