Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After upgrading to 11.10, the association I had created to open SGF files with an application called quarry is lost.

If I select Right-button->Properties->Open With... on an SGF file, quarry is not listed, but it appears in the Right-button->Open With... menu.

What's going on here?

By the way, i tried "mimeopen whatever.sgf" and it works. So mime-types associations are ok, but something is broken in nautilus it seems... For example:

% mimeopen Kogo.sgf

Please choose a default application for files of type application/x-go-sgf

1) Quarry  (quarry)
2) notepad  (wine-extension-txt)
3) GVim Text Editor  (gvim)
4) gedit  (gedit)
5) AbiWord  (abiword)
6) Other...

As you can see, Quarry is properly detected. But in the Properties->Open With dialog in Nautilus, Quarry is not availaible. And because in 11.10 Nautilus doesn't longer provides the option to add a custom command to open an application, i have no way to add a file association.

share|improve this question
    
I think your problem is same as mine asked here: askubuntu.com/questions/61744/…, basically you'll have to use Properties and make association from there –  zetah Oct 15 '11 at 0:00
    
I will do but, when making a new association, the app I want to use(quarry) is not listed. And because they removed custom commands Gnome3, i cannot add it :(. –  dabisu Oct 16 '11 at 18:05

3 Answers 3

I had the same issue with Nautilus not allowing me to set acroread as the default for pdf files. Perhaps you can use something like I did to fix things up. Like you, mimeopen worked fine.

xdg-mime query default application/pdf # show current association

xdg-mime default /usr/share/applications/acroread.desktop application/pdf

This also made firefox open my pdf links with acroread, which was my real goal, because the default evince "Document Viewer" doesn't open up tab panes and opening up 10+ separate viewers with the Unity desktop is r-e-a-l-l-y painful.

Maybe a similar use of xdg-mime can fix your setup too?

share|improve this answer

A very simple solution: You can use PCManFM to add file associations, and these are then shown in Nautilus.

share|improve this answer

If you wish to use a GUI to set mime types ubuntu-tweak Admins tab, File Type Manager will do the job for you. The ap is available from http://ubuntu-tweak.com where you can download the deb file. Once downloaded you click the deb file and the Software Center will install it in the normal fashion. That is how I handled the situation and Nautilus then handled things in the fashion you expect.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.