Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

There is one small issue with Ubuntu that is driving me crazy. Smooth scrolling when reading documents PDF's isn't smooth. I was using evince to read PDF's bigger books 200+ pages. The slightest movement results in a major movement of many pages.

So I blamed evince and the installed xpdf but no its the same thing. Is there anything i can install/fix to allow something scrolling when I read documents?

In LXDE or KDE the PDF viewer has the little up and down scroll arrows in the bottom right corner. Is there anyway to enable these for laptops so we aren't "pulling" at the documents and can scroll ODF's smoothly on laptop's?

share|improve this question
add comment

3 Answers

In Ubuntu 12.04 smooth scrolling is enabled system-wide and many GTK3 applications (most of the default ones) support it. However, the default PDF viewer, Evince, does not yet.

The good news is that smooth scrolling in Evince might be coming as an update. See https://bugs.launchpad.net/ubuntu/+source/evince/+bug/981248.

Also, if you disable overlay scrollbars, scrolling with the touchpad over the regular scrollbar will make the document scroll smoothly.

share|improve this answer
add comment

Well unfortunately I cannot find anyway to directly fix the problem with the overlay scroll bars.

But have found a way to remove them so reading PDF's would again be possible. revert to the default scrollbarsecho "export LIBOVERLAY_SCROLLBAR=0" | sudo tee /etc/X11/Xsession.d/80overlayscrollbars > /dev/null

Found the solution here enter link description here

share|improve this answer
add comment

Try holding alt when pressing the arrow keys.

Found it out today.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.