Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Error is as follows:

The following packages have unmet dependencies.
spotify-client-gnome-support: Depends: spotify-client-qt (= 1: but 1: is to be installed E: Broken packages

Basically spotify-client-qt is too recent under both my Ubuntu/Xubuntu installations.

I cannot force version so as to regress under synaptic either. Can I get an old copy from somewhere? Or will Spotify be updated any time soon?

share|improve this question
up vote 3 down vote accepted

It's a bug in their Packages file:

Package: spotify-client-gnome-support
Version: 1:
Depends: gconf2 (>= 2.12), spotify-client-qt (= 1:


Package: spotify-client-qt
Version: 1:
Depends: libasound2 (>= 1.0.14), libc6 (>= 2.6), libqt4-dbus (>= 4.5.0), libqt4-webkit (>= 4.5.0), libqtcore4 (>= 4.5.0), libqtgui4 (>= 4.5.0), libstdc++6 (>= 4.0.0), libxss1 (>= 1:1.2.0), usbutils, libssl0.9.8
Recommends: libavcodec52, libavformat52

Look at the dependencies for 'spotify-client-gnome-support'. It says "spotify-client-qt (= 1:", but the version that's installed is 1:

The line should be: "spotify-client-qt (>= 1:"

You could create your own repository, or just don't install spotify-client-gnome-support... The latter worked for me ;-)

Edit: Found this on their forums: Mathieu Bérard 3 months ago The functionality provided by spotify-client-gnome-support was integrated in spotify-client-qt with version 1: You can just first remove spotify-client-gnome-support and then upgrade to spotify-client-qt 1:

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.