Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I write a lot of code, and I prefer my editor window (emacs) to be 100% of all my screen space. (ideally, not even title bar, but not going for that yet...).

I usually stretch it out, but in 11.10 (Gnome), there's this really frustrating auto-maximize to a given monitor 'feature'.

I've tried forcing the size to be 2880x900 and setting the window to be non-maximizable in CCSM, but no go.

share|improve this question
add comment

2 Answers 2

I found an Ubuntu forums post that indicated you will need to disable the "Grid" plugin in Compiz Configuration Settings Manager or "CCSM" You may need to install it if it is not installed.

I tested it and was able to drag Firefox across both of my 22" monitors. Hope that's the answer you were after.

share|improve this answer
add comment

In CCSM > Window Management > Window Rules you can set size rules which will make specific windows always be forced to an exact size and screen position, including spanning multiple monitors. I have used this in the past to run blender across multiple displays. This operates based on the window classes. You won't be able to unmaximize the window if you do this though.

Also, I just tried to enable this plugin and Unity instantly crashed. (923567)

Ironically, after Unity crashed and I restarted it manually, it failed to recognize my twinview setup, and now all windows maximize across both monitors! (923569)

share|improve this answer
    
I'd like to suggest xfce. ;-) I've had great success in 11.10 using xfce instead of Unity or gnome. –  Paul Nathan Jan 30 '12 at 16:39
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.