Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running gnome classic on 11.10 and even though I have configured the gnome-terminal profile to hide the menu bar it shows it.

Even when I open the gnome-terminal --hide-menubar it shows the menu bar.

Any idea how to resolve that?

I even used gconf-editor to see if there is a problem with the profile but it has the parameter to show the menubar by default in false.

share|improve this question
    
This doesn't solve your problem, but you could always use xterm if you don't like the menu. –  bntser Oct 14 '11 at 20:22
    
thanks @bntser but I really like gnome-terminal, and if I were to use another terminal I'd use roxterm or eterm :) –  feniix Oct 14 '11 at 22:54
1  
This is very annoying. I found a bug report for this issue here bugs.launchpad.net/ubuntu/+source/gnome-terminal/+bug/875070 –  Naveed Oct 16 '11 at 14:36
    
I even used gconf-editor to see if there is a problem with the profile but it has the parameter to show the menubar by default in false.may be i can help you. –  user46054 Feb 12 '12 at 7:20

1 Answer 1

up vote 15 down vote accepted

In my case it was related to Eliminate the top "mac-ish" file/edit/view/... menu after installing gnome?

When I moved my top bar away with Alt + Right click (for example to the right side of the screen) an extra menubar showed up on the top of the screen. It was probably hidden under the top bar I moved away.

After running sudo apt-get remove appmenu-gtk3 appmenu-gtk appmenu-qt and a reboot gnome-terminal --hide-menubar worked again :-)

share|improve this answer
    
Thanks, that's been hacking me off since I upgrade to gnome 3. –  El Yobo Dec 1 '11 at 0:48
    
Just confirm it worked in cairo-dock session with gnome-panel loaded manually (from gnome-session-fallback) which doesn't have a menubar. –  darent Dec 15 '11 at 22:00
    
Excellent! Works on 11.10! –  v2r Aug 11 at 14:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.