Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I updated from Ubuntu 11.04 to 11.10 today.

Instead of using update manager, I upgraded using sudo do-release-upgrade command in terminal. However, an blackout causes the computer to switch off and the installation is terminated halfway accidently.

After I switched on the computer, the Ubuntu 11.04 won't start it's GUI. So, I used Ctrl+Alt+F1, logged in and used sudo do-release upgrade again to resume the upgrade.

After the upgrade, the computer restarted, after choosing Ubuntu 11.10 from grub, the screen goes black, no bootloader or anything. Here is the screenshot of the screen after something appears.. ??

After this appears, I used Ctrl+Alt+F1 again, logged in and used startx command. Ubuntu is back to normal. When I restarted again, it goes back to tty1. I have to use sudo reboot to get restart again, however, this time same thing happens and Ubuntu 11.10 won't start GUI automatically.

How do I fix this?

share|improve this question
I'm kind of fixed this; apparently some of the important package are not installed during the upgrade. I reinstalled ubuntu-desktop and lightdm, and no longer see the error. However, the bootloader still not showing up, and it takes extremely long to get to login screen. I think there are some packages that need to be installed, but I don't know how. I tried sudo apt-get update and it shows everything is up to date. – Death Oct 22 '11 at 8:55

I had the same behaviour with my Lenovo Ideapad Y560p running 11.10. First install went fine but after restarting it didn't boot the GUI.

The issue was to do with the graphics driver. In the kern.log file I found the message "failed to load module "fglrx"". Which is the ATI Catalyst driver for linux.

So I did a "sudo apt-get install fglrx" . It installed the driver and now it boots up every time.

share|improve this answer

ufff the same happened to me today...the problem is that we downloaded the ubuntu SERVER not the DESKTOP, so the desktop will not install :P you need to download the desktop one in order to use it. you can download the desktop version here:

share|improve this answer
-1 It would be much easier to install the metapackage ubuntu-desktop. – Nathan Osman Oct 19 '11 at 16:50

If an APT operation (such as a release upgrade) was cancelled, usually sudo dpkg --configure -a will configure the unconfigured packages, if there are any.

Hold down SHIFT when booting up - you should see the GRUB2 screen. Navigate to Previous Linux versions and press Enter. Find the one at the bottom and press Enter on it. (Move around the menus with the arrow keys) This will boot an old kernel, and if this helps, then the latest version of the Ubuntu kernel happens to be incompatible with your computer. You can continue to boot your old kernel via this method if it helps.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.