Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just played Frozen Synapse 2 days ago using Ubuntu 11.04. Now with a clean upgrade of 11.10, I cannot play the game anymore. When I run the game in terminal I get this error:

Alert: Error Unable to initialize OpenGL.  (Error: Failed loading libGL.so.1)
Exiting

What could be the problem? I'm using Intel graphics adapter by the way. The one that Intel Corei3 comes in stock in Laptops.

share|improve this question
    
Sounds like the same kind of trouble Skype is having. Try with the 32bit version... –  badp Oct 14 '11 at 18:52
    
This question appears to be abandoned, if you are experiencing a similar issue please ask a new question with details pertaining to your problem. If you feel this question is not abandoned, please flag the question explaining that. I am flagging this for closure :) –  Ringtail Feb 28 '12 at 17:45
add comment

3 Answers 3

I'm on amd64 version of oneiric and here's what I had to do.

  1. Install ia32-libs
  2. Run FS like this: LD_LIBRARY_PATH=/usr/lib/i386-linux-gnu/mesa ./FrozenSynapse
share|improve this answer
add comment

I've got a similar problem running "Trine 64bit" on my recent ubuntu 11.10 installation. I fix it installing some additional packages.

libgladeui-2-0 libgladeui-common libglade2-0

After installing these packages incomes a new problem due to the lack o S3TC extensions on the intel opensource drivers. I finally fix this problem installing some packages from the xorg-edges ppa

Now Trine is running fine. Maybe the same solution can work for Synapse.

share|improve this answer
    
I fixed Trine in a similar manner, but Frozen Synapse and others are not fixed. My guess is a few more missing libraries. –  cprofitt Oct 16 '11 at 19:18
    
Yep. I still get the same error. I'll try Trine later and get you some update about it. –  user20655 Oct 19 '11 at 13:46
add comment

This appears to be an issue with the way the libraries are handled.

see the thread: http://frozenbyte.com/board/viewtopic.php?f=23&t=3706

The developers are reporting:

"It seems that libglade has no multiarch support, it's mainly a shared library packaging issue, but we are too late in debian and ubuntu developpement cycle to ask for a fix. Is there any alternative to request request repackaging this library to get this installer (and game) to run in Oneiric ?"

They are apparently working on a solution. For now my Frozenbyte Humble Bundle programs simply do not run on Ubuntu 11.10.

share|improve this answer
    
I hope they are working on a solution right now. I cannot play FrozenSynapse anymore. I don't want to revert to 11.04 either. By the way, will FrozenSynapse work out-of-the-box in Fedora 15? –  user20655 Oct 20 '11 at 15:52
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.