Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Just performed a fresh install and sound plays from the speakers but not from the headphones. No sound at all. If I pull the jack out, then push it in slightly, it works but sound plays from the speakers also.

    lspci | grep -i audio
    00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio            Controller (rev 02)

I am using an MSI Wind u100 netbook. F

share|improve this question

2 Answers 2

up vote 2 down vote accepted

I was in the same quandary, running ubuntu 11.10 I would plug in my headphones and the sound would stop from my speakers but no sound would emit from my headphones. Below is a possible workaround that worked for me:

Left click on the upper right speaker/sound icon and then in the context menu that appears, click on sound settings at the bottom.

Now click on the "output" tab. Here you should see your audio device for output and at the very bottom a drop down that is labled "connector".

When I plug in my headphones, this drop down automatically changes to "Analog Headphones". If I then click on the drop down menu and change this to be "Analog Speakers" without unplugging or changing anything else, the sound just starts to work again in my headphones.

Hope that helps.

share|improve this answer
    
That worked perfectly. Thank you. –  CBowley603 Oct 17 '11 at 4:25
    
I found that some laptops do not have a second option in that dropdown list. Try installing alsa-hda-dkms from the daily repositories. –  beanaroo Mar 2 '12 at 13:11

I have this problem in Oneiric on various laptops too.

Found a permanent solution:

sudo add-apt-repository ppa:ubuntu-audio-dev/alsa-daily

sudo apt-get update

sudo apt-get install alsa-hda-dkms

Let me know if it works :)

share|improve this answer

protected by Community Oct 20 '11 at 10:19

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.