Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I choose in LightDM gnome-classic session.

I launched gnome3 with the classic style (the fallback). But compiz doesn't work.

If I execute compiz --replace compiz starts working.

But how enable automatic loading of compiz? If I add compiz to autostart in gnome starting takes lot of time.

share|improve this question
    
possible duplicate of How do I enable compiz in Gnome Classic? –  WarriorIng64 Mar 14 '12 at 8:45
add comment

1 Answer

up vote 1 down vote accepted

Problem was in file /usr/share/gnome-session/sessions/gnome-classic.session in key RequiredProviders in parameter notifications

This parameter causes to fail loading of gnome-classic (which have window manager gnome-wm), and system try to load gnome-fallback (which have window manager metacity). I remove notifications parameter from RequiredProviders key, and my gnome-classic now loading with compiz (gnome-wm loads compiz).

Full story of solving this problem in Russian language: http://forum.ubuntu.ru/index.php?topic=170434.0

share|improve this answer
    
The disadvantage of using this method is that you cant add or customise the panels - I think you can only do this via gnome-fallback mode... unless you have any other ideas? –  fossfreedom Oct 17 '11 at 8:45
    
You mean that Alt+Button2 didnt work? I have same problem, its because of compiz, I change key binding settings in compiz-config - so now I can cutomize my gnome panels –  avi9526 Nov 3 '11 at 14:38
    
where is compiz-config ? It is not on my 11.10 system; apt-get does not know about it. I do have Compiz Config Settings Manager (ccsm) - is that what you mean? –  djb Jan 6 '12 at 13:39
    
yes, sorry about that, I mean ccsm. Its hard to clear Alt+Button2 (or Button3, dont remember) keybind because its reset after restart, I dont know why, seems bug. The solution is to set another keybind for window menu. –  avi9526 Jan 15 '12 at 3:57
    
Good that you wrote some things in English. I am Brazilian and for me Russian is like Chinese. Thanks for sharing text in the universal language. It seems that the parameter "notifications;" is useless in the classic gnome session... –  user51837 Mar 24 '12 at 2:54
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.