Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When applying themes that have transparency set on the top bar (gnome shell/gnome 3), there is a unity or nautilus bar behind it that makes everything look like a mess. That bar contains menu items like : file edit, about, help Once i did the help button, when gnome 3 didn't start properly (so i was able to access this menu), and it said "Nautilus". I've seen that ppl around the net have this problem but does anyone here have a solution?

share|improve this question

closed as too localized by Marco Ceppi Nov 13 '11 at 6:50

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
What kind of graphic card do you have ? And whether do you use proprietary driver or not ? For me, it works great if I use radeon free driver (ATI card M86), but looks like a mess with the proprietary one. More especially, the symptoms are : I've the bar bug but a lot of graphic artefact too. For the moment I'm waiting for the new ATI fglrx driver to see if it will fix the problem. –  user27288 Oct 14 '11 at 19:52
    
it is not it . Thank you ! –  vanjadjurdjevic Oct 15 '11 at 9:41
    
possible duplicate of Problem with gnome3-shell (top taskbar) –  fossfreedom Oct 31 '11 at 21:00
    
Why is this closed? It is very valid, loads of people are having this issue.. –  pst007x Mar 24 '12 at 0:15

3 Answers 3

This is because nautilus is handling the desktop You can disable it using gnome tweak tool if you dont have it it's

sudo apt-get install gnome-tweak-tool

to install it

Then just turn "have file manager handle desktop" off as shown here

share|improve this answer
2  
this solution isn't really handy is it... cuz i won't have my desktop anymore –  vanjadjurdjevic Oct 14 '11 at 21:02

I had the same problem myself, and after looking around I solved it. Fire up Synaptic and remove "appmenu-gtk" and "appmenu-gtk3" Log out or reboot and the menu should be gone. You aren't using Unity so you don't need them anyways.

share|improve this answer
    
Tried it not working :) –  vanjadjurdjevic Nov 11 '11 at 21:05
    
Worked ok for me. Thanks ;-) –  Pavlos G. Mar 4 '12 at 21:49

It's definitely a nautilus bar. If you kill nautilus processes, it goes away, but it comes back as soon as you start a "Files" activity. I have the same thing on my machine, but it's on my secondary monitor rather than behind my Gnome 3 bar. I've no idea how to get rid of it, unfortunately. I'm guessing it's related to the unified menu deal from Unity...

share|improve this answer
    
I even tried downgrading nautilus to the previous version (lucid lynx) but it has too many dependencies ... I like this gnome 3 and it could be powerful, if just it had no bugs... –  vanjadjurdjevic Oct 14 '11 at 21:04

Not the answer you're looking for? Browse other questions tagged or ask your own question.