Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just upgraded to 11.10 from the update manager. It doesn't seem to want to boot when using the 3.0 kernel option but does with the 2.6 kernel option.

It gets stuck at the final dot of the Ubuntu bootsplash.

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

I have the same issue. I upgraded to 11.10 from 11.04 on AMD64. I had to revert to the 2.6.38 kernel in order to boot properly.

I have a suggestion: Try changing

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

to

GRUB_CMDLINE_LINUX_DEFAULT="text" 

in the file /etc/defaults/grub

and do update-grub, and reboot. You will know why the boot fails.

In order to update the /etc/defaults/grub file. Press Ctrl + Alt + F1 at the splash screen to boot into alternative console/ environment. F1 can be replaced with F2 - F6... You will need to enter root password to proceed at this step.

I got ubuntu 11.10 with linux kernel 3.0 working. If you have an nvidia graphics card, try this. Boot into 2.6.38, and disable nouveau kernel by adding the line

blacklist nouveau

in the file /etc/modprobe.d/blacklist.conf.

Install nvidia driver by :

sudo apt-get install --reinstall nvidia-current

Now, do an

update-initramfs -u -v -k 3.0.0-12-generic 

in order to update the ramdisk for kernel 3.0, and also do

update-grub 

(just in case). Now, if you try to boot into Kernel 3.0, it will work. (Worked for me...)

share|improve this answer
    
Its all very strange because the live cd works fine. The booting with v.3 doesn't give away any clues its just blank, theres no (fail) flag. It just stops. –  davbren Oct 31 '11 at 18:20
1  
I got ubuntu 11.10 with linux kernel 3.0 working. If you have an nvidia graphics card, try this. Boot into 2.6.38, and disable nouveau kernel by adding the line "blacklist nouveau" in the file /etc/modprobe.d/blacklist.conf. Install nvidia driver by : sudo apt-get install --reinstall nvidia-current. Now, do an update-initramfs -u -v -k 3.0.0-12-generic in order to update the ramdisk for kernel 3.0, and also do update-grub (just in case). Now, if you try to boot into Kernel 3.0, it will work. (Worked for me...) –  Sriram Murali Oct 31 '11 at 19:10
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.