Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to install ubuntuone-control-panel-gtk, and I got the following message:

$ sudo apt-get install ubuntuone-control-panel-gtk 
Reading package lists... Done 
Building dependency tree 
Reading state information... Done 
Some packages could not be installed. This may mean that you have 
requested an impossible situation or if you are using the unstable 
distribution that some required packages have not yet been created 
or been moved out of Incoming. 
The following information may help to resolve the situation: 

The following packages have unmet dependencies: 
ubuntuone-control-panel-gtk : Depends: ubuntuone-installer but it is not installable 
E: Broken packages

The part

Depends: ubuntuone-installer but it is not installable

Is it because I'm using Ubuntu 10.10?

By the way, packages in the PPA doesnt mention ubuntuone-installer. Any idea why I can't install the ubuntuone-control-panel-gtk here?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

The ubuntuone nightly PPAs are automated builds - python code. The packages for lucid/maverick/natty are built from the same build recipe as for Oneiric and Precise.

However - the developers have added a dependency on ubuntuone-installer - a package that only exists in the oneiric and precise repositories.

Possibly you may be able to force install (sudo apt-get -r install ubuntuone-control-panel-gtk) but that might/probably will just leave you in an inconsistent package management state.

Another suggestion would be to download and attempt to install the oneiric deb file of the ubuntuone-installer (see the link above - sudo dpkg -i [deb file name]). Again - potentially can leave your system in an unstable state - if you have a disk image to restore from, might be worth a try. There maybe other dependencies for ubuntuone-installer you may also have to satisfy.

A similar question was raised on how to install ubuntuone-control-panel in Kubuntu (Lucid) exists. I note the maintainer of that PPA has also backported to maverick. Again - your system may be left in an unstable state - but might be worth a shot - note the warnings in that answer.


Linked Question:

  1. How do I install Ubuntu One in Kubuntu?
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.