Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a digital camera CANON PowerShot A470, and Xubuntu 11.04 installed on my PC. When i attach the camera to PC Xubuntu don't mount it, and don't show attached device...

How i can use camera on Xubuntu?

share|improve this question
add comment

3 Answers

I’ve had the same problem and I solved it by installing Nautilus. Unlike Thunar (the default file browser for Xubuntu), Nautilus will show the camera in the sidebar.

share|improve this answer
add comment

This is an old thread, but I thought I would post what worked for me. I own a Canon Powershot SX150 IS and am running xubuntu 10.04. The file browser, Gigolo, works great for getting the files off the camera onto the computer.

share|improve this answer
    
I have had a similar problem with PowerShot S90. It does not connect automatically but connecting it through Gigolo and then using Thunar works ok. –  Václav Zeman Jul 8 '12 at 9:55
add comment

I also had problems with some PowerShot models. The only thing that worked for me, was taking the SDcard out of the camera, and copy the files from that. I think it has something to do with some Canon models don't mount their memory like usual "external drives".

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.