Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After updating to Ubuntu 11.10, I was severly disturbed by Dash and wanted to go back to Ubuntu Classic. So I tried to read up, and found Compiz SettingsManager. In there, I clicked "on" never hide menus. For some reason this made all my menus at the top of the screen (volume, network, my login identity, and shutoff, etc) disappear - as well as the quickstart menu to the left (Unity).

I am not very technical, so I have a hard time finding any programs now, and I just got on the internet by clicking on a link in a document, that I was fortunate to have on my Desktop. Without it, I wouldn't be able to ask for help.

What I wish for is a) to get back the menu at the top, b) to restore the Ubuntu Classic without the irritating launcher and Dash, c) these two things to not disappear every time there is a new version of Ubuntu.

Any help is greatly appreciated.

share|improve this question
    
possible duplicate of Unity 3D doesn't work anymore, just shows a menu on the top –  Jorge Castro Nov 19 '11 at 3:39
    
Try the question I just linked, see if that helps. –  Jorge Castro Nov 19 '11 at 3:40
add comment

3 Answers

To get some sort of Ubuntu classic, install the gnome-shell and gnome-session-fallback packages. To do that, type in a Terminal (Dash->Terminal) window:

sudo apt-get install gnome-shell gnome-session-fallback

Then reboot, and on the session selection screen, select GNOME fallback or GNOME Classic (forgot which one it was)

share|improve this answer
    
I tried this, but there is no session selection screen and no GNOME Fallback or GNOME Classic, and there are still no menus, so I cannot select any session settings. Thanks anyway. –  Lennart Guldbrandsson Oct 14 '11 at 17:57
    
Okay, I found it. Thanks. However, it doesn't seem to be a way to add new program starters to the menu bar. Or is there? –  Lennart Guldbrandsson Oct 14 '11 at 18:32
add comment

i have just installed 11.10, not upgraded from 11.04 (i hate that).

i installed compizconfig-settings-manager AND compiz-fusion-plugins-extra

did some tweaks for the unity dash

rebooted (to check boot logs)

surprise : i can see 'Ubuntu Classic' in the login menu

share|improve this answer
add comment

You need to fire up the settings manager again and make sure the Unity plugin is checked, or you can try to reset unity's configuration:

It looks like someone gave you bad advice on how to set up classic. Here's how to revert to a more classic session:

share|improve this answer
    
About the first thing, this is the result of trying to reset Unity in the terminal: –  Lennart Guldbrandsson Oct 14 '11 at 18:00
    
(several things done) compiz (core) - Warn: unhandled ConfigureNotify on 0x3c000a4! compiz (core) - Warn: this should never happen. you shouldprobably file a bug about this. compiz (core) - Warn: unhandled ConfigureNotify on 0x3c000a7! compiz (core) - Warn: this should never happen. you shouldprobably file a bug about this. –  Lennart Guldbrandsson Oct 14 '11 at 18:01
    
@LennartGuldbrandsson Add this information to your question, the way the site works is you keep adding detail to your question, which bumps it. The more information you keep adding the easier it will be for the next person to help, thanks! –  Jorge Castro Oct 14 '11 at 19:01
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.