Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Ok, i have been using Ubuntu since 8.04 on my old laptop, but some months ago i got a new one and since that day i'm having some bad times.

First lemme describe it. It's a CCE (brazilian brand) WM545B-T with 4gb DDR3, Intel i5 Sandy Bridge 2500k iirc, Intel HD 3000 (great integrated card btw) and a 500gb 5200rpm HD (yeah, i know...). It's motherboard is, iirc, a Intel HM65.

As i reported in a question before, when i first got it, i tryed to install Ubuntu 11.04 and got some weird screen bugs. I got around that installing SuperOS, a Ubuntu 11.04 based distro.

Yesterday at 8am (brazil time) i saw some Ubuntu CDs from the oficial release repos (before the oficial release by Canonical), downloaded via torrent, checked md5 and used unetbootin to burn it to a pendrive.

Started the install like i always do any other OS install, the weird screen bug was there again... but this time i was able to click the first option and start the Live CD. Great... i was finally gonna use my loved distro again. Oh man, i was wrong.

The Live CD worked great and insanely fast. I runned the installer and went to the advanced options for partitions. I have 3 NTFS partitions... one with 20gb for W7 64bits, one with 100mb with system files that W7 created and the rest is for my personal files. Made a 25gb ext4 one for Ubuntu and a 4gb swap one. The bottom of the install ask me where i wanna install the bootloader, with /dev/sda (my hd) by default. Then installed it and the install went without a problem. Made me happy ofc.

When the laptop was booting again, the first problem. It did not boot... just freeze at post or restart. Ok... went to the Live CD again and this time tryed a different setup for my partitions.

Tryed to install the bootloader in /dev/sda2, with Windows Boot Loader. This time it booted... but on a EFI Shell, something i have no idea about what is. Tryed again... created swap, ext4 for Ubuntu and this time also created a EFI partition (i thought Hey, it says EFI, lets try it lol)... same EFI Shell saying something about and then gimme a Shell> inpurt commands here line of command.

I have never see this EFI Shell before and i can't find infos about it on the internet. Not infos i can use to install Ubuntu at least. Anyone know what is that or how can i install my lovely distro?

Right now i have some options in mind: 1. Format my ENTIRE HD losing 232gb of important fles and try to install Ubuntu 11.10 on the entire HD to see what happens; 2. Install W7 from zero and install Ubuntu with Wubi losing performance with it; 3. Use Fedora (that install and boot normaly) or some Ubuntu 11.10 distro based (that will take sometime to appear); 4. Delete my W7 partition, install Ubuntu 11.10 and then install W7 again... recover grub and see what happens...

Anyone have an answer for this question before i try one of those ideas? My obvious idea is the problem is based on my boot since the Live CD works ok and other distros based on Ubuntu runs fine. I have tested Ubuntu 10.10 and give me same 11.04 issues... but ElemetaryOS, based on 10.10, works fine. I don't know what tweak they do on the boot... but something happens there. Anyone have an answer for this?

EDIT: Ok, i think i may know what is going on. Runned sudo fdisk -l and this is what i get from it:

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x2b510800

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1            2048      206847      102400    7  HPFS/NTFS/exFAT
/dev/sda2          206848    40962047    20377600    7  HPFS/NTFS/exFAT
/dev/sda3       102402048   976771071   437184512    7  HPFS/NTFS/exFAT
/dev/sda4        40964094   102402047    30718977    5  Extended
/dev/sda5        94191616   102402047     4105216   82  Linux swap / Solaris
/dev/sda6        40964096    94189567    26612736   83  Linux

If you take a close look, there is no "*", so maybe it means there is no boot device set? Then when i try to boot from HD it doesn't find any bootable device and give me the internal shell (EFI Shell). Anyone can help me fix this?

share|improve this question
You should post your comment as an answer! – Jorge Castro Oct 28 '11 at 16:34
My oh my, that's a lot of emphasis. – Oli Oct 28 '11 at 16:52

Ok, solved the problem. Probably did not used the best solution but well... at least it's booting and stuffs. What i did was delete Windows and Ubuntu partitions, make new one for both, install Ubuntu and then install W7... then restaured grub and done. Ubuntu working.

Edit: Answering it here as i have been told to ;)

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.