Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Samsung N150 plus netbook with a Broadcom BCM4313 wireless adapter. Today I installed Ubuntu 11.10 desktop 32 bit. When I try to connect to the wireless internet router I repeatedly receive this message "Authentication required by wireless network."

I had this same problem with Ubuntu 10.04.

Are there any suggestions?

Thanks in advance..

share|improve this question
    
It sounds like this is a problem caused by your router, not Ubuntu. –  Trevor Oct 14 '11 at 16:23

3 Answers 3

This means that the network that you are trying to connect to is secured by WEP, WPA, or WPA2. You need to enter the network password to be able to connect.
EDIT: Try this in a Terminal (Dash->Terminal) window:

sudo ifconfig wlan0 down
sudo dhclient -r wlan0
sudo ifconfig wlan0 up
sudo iwconfig wlan0 essid "YOUR NEWORK NAME HERE"
sudo iwconfig wlan0 mode Managed
sudo dhclient wlan0
share|improve this answer
    
thanks for the fast reply.. but i am already entering the network password but it keeps re asking for it again and again ! and the problem is not in the internet modem itself cause i faced the same problem when tried to receive internet from my other laptop through an ad-hoc connection.. –  sarmad Oct 14 '11 at 17:46
    
I edited my post. Take a look. –  MiJyn Oct 14 '11 at 21:24
    
Thanks for your reply , but unfotunately it didn't work , and ended up with non-working network connections (neither wireless nor wired) ! , i just re-installed ubuntu again and really hope to find a solution for the wifi issue .. :( –  sarmad Oct 15 '11 at 8:02
up vote 0 down vote accepted

Thanks for everyone who tried to help..

how it's been solved :

  1. installed Wicd (using wired connection )
  2. removed network manager :

    sudo apt-get remove network-manager
    

    then :

    sudo apt-get purge network-manager network-manager-gnome
    
  3. changed the security type of the internet modem from WPA/WPA2 to WEP-hex (coz the wireless lan never connected to the modem with WPA/WPA2 ).. now every thing working fine with the wireless lan..

share|improve this answer

I also faced somewhat similar problem but there is a trick:
Instead of using DHCP use a static IP.

share|improve this answer
    
tried and didn't work.. the same problem :(( –  sarmad Oct 15 '11 at 9:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.