Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently bought a new laptop (Asus X53S series) that has two GPUs, an NVidia GeForce GT 540M and an integrated Intel GPU (I believe it's called Intel HD graphics 3000). I installed the recommended restricted NVidia drivers after a clean Ubuntu 11.10 install. In the 'additional drivers' program I get the message: "This driver is enabled and in use", although when I try to open the NVidia X Server Settings it says "You do not appear to be using the NVIDIA X driver." which seems to be the case since Ubuntu only starts using Unity 2D.

I've had the same issue in 11.04 and I was forced to use the nouveau driver just to get unity working, but since I get quite a few crashes with it I really want to get the propriety driver working this time around. Since I've never had this issue with older laptops, I can only assume it is caused due to the dual gpu configuration. How do I get Ubuntu to use the propriety drivers, or is there any workaround to get the integrated Intel GPU to be ignored by Ubuntu?

Alternatively, has anyone got Unity working with a similar setup?

share|improve this question
    
possible duplicate of How well do laptops with Nvidia Optimus work? –  Jorge Castro Feb 28 '12 at 0:53
add comment

1 Answer

You need to install a program called Ironhide from the ironhide PPA

sudo apt-add-repository ppa:mj-casalogic/ironhide && sudo apt-get update && sudo apt-get install ironhide ironhide-ui

This will install software that will allow switching between the Nvidia GPU and the Intel GPU, it will also shut down the Nvidia when it is not needed...

It doesn't work perfectly and most of the time the Intel GPU is being used, but it does allow for unity 3d to work.

I haven't had any luck with the GUI portion of Ironhide though it just crashes.

I've also had to type this sudo modprobe nvidia-current to activate the nvidia card..

You also have to run programs that you want to run on the nvidia card from the command prompt..

ie: optirun google-chrome, will run google-chrome with the nvidia-gpu

PS: You can't disable the Intel Adapter because the technology that is used for the dual GPU setup is based on a switch GMA that allows for other GPU's to render. There is no direct connection to the Nvidia GPU.

Although some bios's will allow you to disable the intel chip in the settings, then Just the nvidia can be used.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.