Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I'm using NoMachine NX Free Edition (not FreeNX)

After upgrading Ubuntu from 10.04 to 10.10, applications in remote sessions do not show a window title.

Has anyone experienced a similar issue or knows what might fix it?

I'm running nxserver 3.4.0-14 (x64)

Update (2010-11-12): this has been fixed in the latest NX Windows Client

share|improve this question

3 Answers 3

up vote 1 down vote accepted

Yes, I have the same problem... There is 2 "solutions" I have found on google for the moment : - Downgrade the metacity package to metacity_2.30.1-0ubuntu1... (from -

Anyway... I found that NX performances are not as good as on lucid... :(

share|improve this answer
Disabling the render extension did the trick. Thanks! – Diego Mijelshon Oct 15 '10 at 11:47

Confirming, upgrading windows nxclient to 3.4.0-10 (from 3.4.0-7 for me; on Windows XP) worked perfectly. Tried all or most of the other fixes and none worked for me.

share|improve this answer

Uninstalling the client and installing latest fixed the issue. In my case, the problem was that connecting through NX resulted in windows with invisible window borders, if I calculated the place where the close icon was, the window closed, minimize or maximized.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.