Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In 11.04 I used the unity-preferences tool (called menu and launcher in the the dash I believe) to set Unity to only reveal when the mouse was moved to the upper corner. I liked this method better as there was less of a chance of accidentally opening the launcher.

Now in 11.10 unity-preferences is gone, and the corner no longer opens up the launcher. That's fine, but now the launcher won't open at all. I can't hover over the edge of the screen to open the launcher. I'm guessing something is still respecting the "corner only" launch option I had set previously, but the new window controls are preventing that from triggering the launcher. And now that unity-preferences has been removed, I have no way to set it back.

I looked through all of the settings for unity in gconf, but couldn't find anything pertaining to this specific setting, only the compiz only settings.

Does anyone know where the old unity-preferences tool stored its setting? Or could this be a different issue?

share|improve this question

To adjust the reveal mode of the Launcher, you can use compizconfig-settings-manager Install compizconfig-settings-manager. To install CCSM, run the following command from the terminal:

sudo apt-get install compizconfig-settings-manager

In CCSM, look for Ubuntu Unity Plugin and click on the option for Reveal mode. Using the Reveal mode, you can choose which part of the screen should trigger the launcher.

You might want to configure the launcher to never hide such that you can use the launcher properly.

share|improve this answer
Yep, tried that. It didn't work. It still doesn't open the launcher. – Gaidin Oct 16 '11 at 18:00

The workaround was to switch to Unity 2D until a fix was issued. I did that and got it back, but then switching back to 3D also seemed to start working again. It looks like today's updates contain the fix because it's staying enabled in 3D for me. Try running updates and see if that helps. The launcher menu is gone, but CCSM that Jokerdino suggested works.

share|improve this answer
I honestly just switched to gnome shell. I'm liking that much better. – Gaidin Oct 20 '11 at 2:53

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.