Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I tried upgrading my Toshiba Satellite laptop with NVidia graphics card from 11.04 to 11.10 - it hung and failed, so I reinstalled from scratch as I had no other choice.

When the system boots, it just sits on the black screen saying "disconnected from plymouth". I've done Ctrl-Alt-F1 and can access the command line without any problems - I tried doing startx from there but it just says something to the effect of nv module not found.

I uninstalled and reinstalled the nvidia-current driver, made no difference. Also tried dpkg-reconfigure lightdm, and chose gdm. This worked sort-of, but I can't log in - no matter what I choose (unity, unity2d, gnome) it flashes to a black screen, then back to the login window.

Anyone have any ideas? I can't put up with using Windows for much longer!

share|improve this question

Managed to fix it. For info this appears to have happened because I use an external monitor. The process to fix was:

Disconnect Monitor, reboot Used Ctrl-Alt-F1, logged in as myself, ran startx Prompted by system to install post-release nvidia driver, did that Rebooted Plugged in external monitor, ran nvidia settings tool, enabled the external monitor, saved xorg.conf, all working fine.

share|improve this answer
Welcome to Ask Ubuntu! If you managed to solve your own problem, please mark this answer as accepted so we know the question has been resolved. You can do this by clicking the checkmark icon to the left of your answer. Thanks! – Christopher Kyle Horton Dec 17 '11 at 21:53

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.